diff mbox series

[bug#68500,v2,1/2] gnu: qtscxml: Update to 6.5.2.

Message ID 5bfa707ec1a839e9329c1320a0f152eee8abff30.1709575388.git.sarg@sarg.org.ru
State New
Headers show
Series [bug#68500,v2,1/2] gnu: qtscxml: Update to 6.5.2. | expand

Commit Message

Sergey Trofimov March 4, 2024, 6:03 p.m. UTC
* gnu/packages/qt.scm (qtscxml): Update to 6.5.2.
(qtscxml-5): Add qt5 variant.
(python-pyside-2)[inputs]: Use qtscxml-5.
---
 gnu/packages/qt.scm | 43 +++++++++++++++++++++++++++++++++++++++++--
 1 file changed, 41 insertions(+), 2 deletions(-)


base-commit: 3da49b1472919a62df1fe399638f23a246aa325d
prerequisite-patch-id: 4b5032a22b70bff803b7bbd0693b00984f53a25e
prerequisite-patch-id: 68eb78a4650b2e0880ad3735fbd1f0296adc7de7
prerequisite-patch-id: bb61e272c86d80072ad9dc79c17ecde91127999b
prerequisite-patch-id: 7f3cf0da78d3a019888053ba63cd03c3abd6bf2e
prerequisite-patch-id: f9cc903b8048c8c6fde576fbf38ab110263020e3
prerequisite-patch-id: aba438a3c32ef44149bbc749c1e0b89d00006b3e
prerequisite-patch-id: 51199b8d0dc0c9fd45bca2f8743d83565255ea80

Comments

Maxim Cournoyer March 10, 2024, 1:21 a.m. UTC | #1
Hi,

Sergey Trofimov <sarg@sarg.org.ru> writes:

> * gnu/packages/qt.scm (qtscxml): Update to 6.5.2.
> (qtscxml-5): Add qt5 variant.
> (python-pyside-2)[inputs]: Use qtscxml-5.

Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail>
diff mbox series

Patch

diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 761d12e31f..8a521be3c0 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -2349,7 +2349,7 @@  (define-public qtgamepad
 primary target audience are embedded devices with fullscreen user interfaces,
 and mobile applications targeting TV-like form factors.")))
 
-(define-public qtscxml
+(define-public qtscxml-5
   (package
     (inherit qtsvg-5)
     (name "qtscxml")
@@ -2377,6 +2377,45 @@  (define-public qtscxml
 generating a C++ file that has a class implementing the state machine.  It
 also contains functionality to support data models and executable content.")))
 
+(define-public qtscxml
+  (package
+    (name "qtscxml")
+    (version "6.5.2")
+    (source (origin
+              (method url-fetch)
+              (uri (qt-url name version))
+              (sha256
+               (base32
+                "1jxx9p7zi40r990ky991xd43mv6i8hdpnj2fhl7sf4q9fpng4c58"))
+              (modules '((guix build utils)))
+              (snippet
+               '(begin
+                  (delete-file-recursively "tests/3rdparty")))))
+    (arguments
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (delete 'check)               ;move after the install phase
+          (add-after 'install 'check
+            (assoc-ref %standard-phases 'check))
+          (add-before 'check 'check-setup
+            (lambda _
+              (setenv "ARGS" "-E tst_scion")
+              (setenv "QT_QPA_PLATFORM" "offscreen")
+              (setenv "QML2_IMPORT_PATH"
+                      (string-append #$output "/lib/qt6/qml:"
+                                     (getenv "QML2_IMPORT_PATH"))))))))
+    (build-system cmake-build-system)
+    (inputs (list qtbase qtdeclarative libxkbcommon))
+    (synopsis "Qt SCXML module")
+    (description "The Qt SCXML module provides functionality to create state
+machines from SCXML files.  This includes both dynamically creating state
+machines (loading the SCXML file and instantiating states and transitions) and
+generating a C++ file that has a class implementing the state machine.  It
+also contains functionality to support data models and executable content.")
+    (home-page (package-home-page qtbase))
+    (license (package-license qtbase))))
+
 (define-public qtpositioning
   (package
     (name "qtpositioning")
@@ -4486,7 +4525,7 @@  (define-public python-pyside-2
            qtquickcontrols-5
            qtquickcontrols2-5
            qtscript
-           qtscxml
+           qtscxml-5
            qtsensors
            qtspeech
            qtsvg-5