diff mbox series

[bug#58614,109/187] gnu: Remove rust-progrs-0.1.

Message ID c1235a35fdc3a3a88dcd3511b0dcc28d94ab935b.1666124234.git.efraim@flashner.co.il
State New
Headers show
Series Remove unused crates | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Efraim Flashner Oct. 18, 2022, 8:18 p.m. UTC
* gnu/packages/crates-io.scm (rust-progrs-0.1): Delete variable.
---
 gnu/packages/crates-io.scm | 32 --------------------------------
 1 file changed, 32 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 89fad16445..542319cb14 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -44343,38 +44343,6 @@  (define-public rust-progressing-3
 progress-bars for Rust.")
     (license license:asl2.0)))
 
-(define-public rust-progrs-0.1
-  (package
-    (name "rust-progrs")
-    (version "0.1.1")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "progrs" version))
-       (file-name
-        (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32
-         "108jx8jrv2r1brhvbqfw6fwx298k5fnw3m46kn7lv0jx2wmf0ifz"))))
-    (build-system cargo-build-system)
-    (arguments '(#:tests? #f))
-    (home-page "https://nest.pijul.com/laumann/progrs")
-    (synopsis "Small library for displaying compact progress bars")
-    (description
-     "There are a number of libraries out there that can be used for progress
-display, but in the author's opinion these libraries do it almost right -
-either they eat up too much screen real estate (by not sticking to one line
-per thing that should use progress) or they try to align stuff left and right.
-
-In the author's humble opinion, the best example of just the right amount of
-information vs screen real-estate is in the Git progress output (when cloning,
-pulling, etc).  It uses one line per thing, and may display both percentage
-complete (in cases where it's known) and even throughput (for network
-transfer).
-
-This library mimics the Git way of showing progress.")
-    (license license:gpl2+)))
-
 (define-public rust-proptest-1
   (package
     (name "rust-proptest")