diff mbox series

[bug#58614,030/187] gnu: Remove rust-eax-0.3.

Message ID 1fdf7ba03fb8007d701b3f75ad48567a51bf837e.1666124229.git.efraim@flashner.co.il
State New
Headers show
Series Remove unused crates | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Efraim Flashner Oct. 18, 2022, 8:17 p.m. UTC
* gnu/packages/crates-io.scm (rust-eax-0.3): Delete variable.
---
 gnu/packages/crates-io.scm | 31 -------------------------------
 1 file changed, 31 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index bdab717678..4aafe9e98b 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -19705,37 +19705,6 @@  (define-public rust-easycurses-0.12
 easy.")
     (license (list license:unlicense license:zlib))))
 
-(define-public rust-eax-0.3
-  (package
-    (name "rust-eax")
-    (version "0.3.0")
-    (source
-      (origin
-        (method url-fetch)
-        (uri (crate-uri "eax" version))
-        (file-name
-          (string-append name "-" version ".tar.gz"))
-        (sha256
-          (base32 "0vmpbqncpbj2ldm3fhfz87ija1sk4zk9vad91yd2jjsrbrx6xxz1"))))
-    (build-system cargo-build-system)
-    (arguments
-      `(#:skip-build? #t
-        #:cargo-inputs
-        (("rust-aead" ,rust-aead-0.3)
-         ("rust-cipher" ,rust-cipher-0.2)
-         ("rust-cmac" ,rust-cmac-0.5)
-         ("rust-ctr" ,rust-ctr-0.6)
-         ("rust-subtle" ,rust-subtle-2))))
-    (home-page "https://docs.rs/eax/")
-    (synopsis "Pure Rust implementation of the EAX Authenticated Encryption
-with Associated Data (AEAD)")
-    (description "This package provides a pure Rust implementation of the EAX
-Authenticated Encryption with Associated Data (AEAD) Cipher with optional
-architecture-specific hardware acceleration.  This scheme is only based on a
-block cipher.  It uses counter mode (CTR) for encryption and CBC mode for
-generating a OMAC/CMAC/CBCMAC (all names for the same thing).")
-    (license (list license:asl2.0 license:expat))))  ; at your choice
-
 (define-public rust-ecies-ed25519-0.5
   (package
     (name "rust-ecies-ed25519")