diff mbox series

[bug#53882,19/24] gnu: Add ocmal-ppx-jane.

Message ID 34da3833791425a6168fdcf79c91381ecf469af1.1644350658.git.julien@lepiller.eu
State Accepted
Headers show
Series [bug#53882,01/24] import: opam: Accept tabulations. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Julien Lepiller Feb. 8, 2022, 8:14 p.m. UTC
* gnu/packages/ocaml.scm (ocaml-ppx-jane): New variable.
(ocaml4.07-ppx-jane): Inherit from it.
---
 gnu/packages/ocaml.scm | 116 +++++++++++++++++++++++++++--------------
 1 file changed, 77 insertions(+), 39 deletions(-)

Comments

Simon Tournier Feb. 23, 2022, 4:12 p.m. UTC | #1
Hi Julien,

On mar., 08 févr. 2022 at 21:14, Julien Lepiller <julien@lepiller.eu> wrote:
> * gnu/packages/ocaml.scm (ocaml-ppx-jane): New variable.
> (ocaml4.07-ppx-jane): Inherit from it.
> ---
>  gnu/packages/ocaml.scm | 116 +++++++++++++++++++++++++++--------------
>  1 file changed, 77 insertions(+), 39 deletions(-)
>
> diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
> index ec05987e2c..259b6551f2 100644
> --- a/gnu/packages/ocaml.scm
> +++ b/gnu/packages/ocaml.scm
> @@ -6527,52 +6527,90 @@ (define-public ocaml4.07-ppx-bin-prot
>        (properties '())
>        (license license:asl2.0))))
>
> -(define-public ocaml4.07-ppx-jane
> +(define-public ocaml-ppx-jane

[...]

> +      (list ocaml-base-quickcheck

[...]

> +            ocaml-ppx-fixed-literal

As far I see, this is not defined, i.e., missing.

--8<---------------cut here---------------start------------->8---
[ 78%] GUILEC   gnu/packages/ocaml.go
<unknown-location>: warning: possibly unbound variable `ocaml-ppx-fixed-literal'
--8<---------------cut here---------------end--------------->8---


Cheers,
simon
Simon Tournier March 15, 2022, 2:14 p.m. UTC | #2
Hi Julien,

>> * gnu/packages/ocaml.scm (ocaml-ppx-jane): New variable.

[...]

> [ 78%] GUILEC   gnu/packages/ocaml.go
> <unknown-location>: warning: possibly unbound variable `ocaml-ppx-fixed-literal'

Did you have a chance to look into it?

    <http://issues.guix.gnu.org/issue/53882>

Cheers,
simon
Ludovic Courtès April 5, 2022, 4:07 p.m. UTC | #3
Ping! :-)

zimoun <zimon.toutoune@gmail.com> skribis:

> Hi Julien,
>
>>> * gnu/packages/ocaml.scm (ocaml-ppx-jane): New variable.
>
> [...]
>
>> [ 78%] GUILEC   gnu/packages/ocaml.go
>> <unknown-location>: warning: possibly unbound variable `ocaml-ppx-fixed-literal'
>
> Did you have a chance to look into it?
>
>     <http://issues.guix.gnu.org/issue/53882>
>
> Cheers,
> simon
Simon Tournier April 6, 2022, 7 p.m. UTC | #4
Hi Ludo,

I have v2 which fixes minor things (typo, indent etc.).  The other one
about ocaml-ppx-jane seems an error an my side.

I will send this v2 on this Friday Apr. 8th.

However, the series will be broken because of ocaml-odoc broken [1] by:

--8<---------------cut here---------------start------------->8---
commit bd9eb9ef27496e951c070f5b206c164c0c998483
Author: Julien Lepiller <julien@lepiller.eu>
Date:   Sun Mar 13 14:48:53 2022 +0100

    gnu: dune: Update to 3.0.3.

    * gnu/packages/ocaml.scm (dune): Update to 3.0.3.
    (dune-configurator)[arguments]: Remove vendored dependencies.
    (ocaml4.09-dune-configurator)[arguments]: Extend from dune-configurator.

 gnu/packages/ocaml.scm | 17 ++++++++++++-----
 1 file changed, 12 insertions(+), 5 deletions(-)

--8<---------------cut here---------------end--------------->8---

This series is independant of the failure but it would be cool to shave
the yak. ;-)  I will give a look on this Friday if no one beats me.


1: <https://ci.guix.gnu.org/build/645045/details>


Cheers,
simon
pukkamustard April 7, 2022, 10:04 a.m. UTC | #5
zimoun <zimon.toutoune@gmail.com> writes:

> However, the series will be broken because of ocaml-odoc broken [1] by:
>
> commit bd9eb9ef27496e951c070f5b206c164c0c998483
> Author: Julien Lepiller <julien@lepiller.eu>
> Date:   Sun Mar 13 14:48:53 2022 +0100
>
>     gnu: dune: Update to 3.0.3.
>
>     * gnu/packages/ocaml.scm (dune): Update to 3.0.3.
>     (dune-configurator)[arguments]: Remove vendored dependencies.
>     (ocaml4.09-dune-configurator)[arguments]: Extend from dune-configurator.
>
>  gnu/packages/ocaml.scm | 17 ++++++++++++-----
>  1 file changed, 12 insertions(+), 5 deletions(-)
>
> This series is independant of the failure but it would be cool to shave
> the yak. ;-)  I will give a look on this Friday if no one beats me.


I've already tried shaving the yak (:

https://issues.guix.gnu.org/54596

- pukkamustard
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index ec05987e2c..259b6551f2 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6527,52 +6527,90 @@  (define-public ocaml4.07-ppx-bin-prot
       (properties '())
       (license license:asl2.0))))
 
-(define-public ocaml4.07-ppx-jane
+(define-public ocaml-ppx-jane
   (package
-    (name "ocaml4.07-ppx-jane")
-    (version "0.11.0")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "https://ocaml.janestreet.com/ocaml-core/v"
-                                  (version-major+minor version)
-                                  "/files/ppx_jane-v" version ".tar.gz"))
-              (sha256
-               (base32
-                "0lgppkw3aixrfnixihrsz2ipafv8fpvkdpy3pw8n0r615gg8x8la"))))
+    (name "ocaml-ppx-jane")
+    (version "0.14.0")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/janestreet/ppx_jane")
+               (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32 "1kk238fvrcylymwm7xwc7llbyspmx1y662ypq00vy70g112rir7j"))))
     (build-system dune-build-system)
     (arguments
-     `(#:test-target "."
-       #:ocaml ,ocaml-4.07
-       #:findlib ,ocaml4.07-findlib
-       #:dune ,ocaml4.07-dune))
+     `(#:test-target "."))
     (propagated-inputs
-     `(("ocaml-ppx-assert" ,(package-with-ocaml4.07 ocaml-ppx-assert))
-       ("ocaml-ppx-base" ,(package-with-ocaml4.07 ocaml-ppx-base))
-        ("ocaml-ppx-bench" ,ocaml4.07-ppx-bench)
-        ("ocaml-ppx-bin-prot" ,ocaml4.07-ppx-bin-prot)
-        ("ocaml-ppx-custom-printf" ,(package-with-ocaml4.07 ocaml-ppx-custom-printf))
-        ("ocaml-ppx-expect" ,(package-with-ocaml4.07 ocaml-ppx-expect))
-        ("ocaml-ppx-fail" ,ocaml4.07-ppx-fail)
-        ("ocaml-ppx-fields-conv" ,(package-with-ocaml4.07 ocaml-ppx-fields-conv))
-        ("ocaml-ppx-here" ,(package-with-ocaml4.07 ocaml-ppx-here))
-        ("ocaml-ppx-inline-test" ,(package-with-ocaml4.07 ocaml-ppx-inline-test))
-        ("ocaml-ppx-let" ,(package-with-ocaml4.07 ocaml-ppx-let))
-        ("ocaml-ppx-optcomp" ,(package-with-ocaml4.07 ocaml-ppx-optcomp))
-        ("ocaml-ppx-optional" ,(package-with-ocaml4.07 ocaml-ppx-optional))
-        ("ocaml-ppx-pipebang" ,ocaml4.07-ppx-pipebang)
-        ("ocaml-ppx-sexp-message" ,ocaml4.07-ppx-sexp-message)
-        ("ocaml-ppx-sexp-value" ,ocaml4.07-ppx-sexp-value)
-        ("ocaml-ppx-typerep-conv" ,ocaml4.07-ppx-typerep-conv)
-        ("ocaml-ppx-variants-conv" ,(package-with-ocaml4.07 ocaml-ppx-variants-conv))
-        ("ocaml-migrate-parsetree"
-         ,(package-with-ocaml4.07 ocaml-migrate-parsetree))
-        ("ocaml-ppxlib" ,(package-with-ocaml4.07 ocaml-ppxlib))))
-    (properties `((upstream-name . "ppx_jane")))
+      (list ocaml-base-quickcheck
+            ocaml-ppx-assert
+            ocaml-ppx-base
+            ocaml-ppx-bench
+            ocaml-ppx-bin-prot
+            ocaml-ppx-custom-printf
+            ocaml-ppx-expect
+            ocaml-ppx-fields-conv
+            ocaml-ppx-fixed-literal
+            ocaml-ppx-here
+            ocaml-ppx-inline-test
+            ocaml-ppx-let
+            ocaml-ppx-module-timer
+            ocaml-ppx-optcomp
+            ocaml-ppx-optional
+            ocaml-ppx-pipebang
+            ocaml-ppx-sexp-message
+            ocaml-ppx-sexp-value
+            ocaml-ppx-stable
+            ocaml-ppx-string
+            ocaml-ppx-typerep-conv
+            ocaml-ppx-variants-conv
+            ocaml-ppxlib))
+    (properties `((upstream-name . "ppx_jane")
+                  (ocaml4.07-variant . ,(delay ocaml4.07-ppx-jane))))
     (home-page "https://github.com/janestreet/ppx_jane")
     (synopsis "Standard Jane Street ppx rewriters")
     (description "This package installs a ppx-jane executable, which is a ppx
 driver including all standard Jane Street ppx rewriters.")
-    (license license:asl2.0)))
+    (license license:expat)))
+
+(define-public ocaml4.07-ppx-jane
+  (package-with-ocaml4.07
+    (package
+      (inherit ocaml-ppx-jane)
+      (version "0.11.0")
+      (source (origin
+                (method url-fetch)
+                (uri (string-append "https://ocaml.janestreet.com/ocaml-core/v"
+                                    (version-major+minor version)
+                                    "/files/ppx_jane-v" version ".tar.gz"))
+                (sha256
+                 (base32
+                  "0lgppkw3aixrfnixihrsz2ipafv8fpvkdpy3pw8n0r615gg8x8la"))))
+      (propagated-inputs
+        (list ocaml-ppx-assert
+              ocaml-ppx-base
+              ocaml-ppx-bench
+              ocaml-ppx-bin-prot
+              ocaml-ppx-custom-printf
+              ocaml-ppx-expect
+              ocaml-ppx-fail
+              ocaml-ppx-fields-conv
+              ocaml-ppx-here
+              ocaml-ppx-inline-test
+              ocaml-ppx-let
+              ocaml-ppx-optcomp
+              ocaml-ppx-optional
+              ocaml-ppx-pipebang
+              ocaml-ppx-sexp-message
+              ocaml-ppx-sexp-value
+              ocaml-ppx-typerep-conv
+              ocaml-ppx-variants-conv
+              ocaml-migrate-parsetree
+              ocaml-ppxlib))
+      (properties '())
+      (license license:asl2.0))))
 
 (define-public ocaml-splittable-random
   (package
@@ -6621,7 +6659,7 @@  (define-public ocaml4.07-splittable-random
                  (base32
                   "0l1wbd881mymlnpzlq5q53mmdz3g5d7qjhyc7lfaq1x0iaccn5lc"))))
       (propagated-inputs
-        (list ocaml-base ocaml4.07-ppx-jane ocaml-migrate-parsetree))
+        (list ocaml-base ocaml-ppx-jane ocaml-migrate-parsetree))
       (properties '())
       (license license:asl2.0))))