diff mbox series

[bug#70693,v2,2/3] gnu: Add po4a-minimal.

Message ID be6d275a1a45d831adb0129755a991606b54dcdc.1715111123.git.mail@cbaines.net
State New
Headers show
Series [bug#70693,v2,1/3] gnu: nss/fixed: Tweak performance test. | expand

Commit Message

Christopher Baines May 7, 2024, 7:45 p.m. UTC
The main reason is to avoid the texlive-updmap.cfg input indirectly pulling in
nss, which has a very time consuming testsuite.

* gnu/packages/gettext.scm (po4a-minimal): New variable.

Change-Id: If8d46a18a02e57d5427852e8e122de01f970ded4
---
 gnu/packages/gettext.scm | 13 +++++++++++++
 1 file changed, 13 insertions(+)

Comments

Ludovic Courtès May 9, 2024, 2:11 p.m. UTC | #1
Christopher Baines <mail@cbaines.net> skribis:

> The main reason is to avoid the texlive-updmap.cfg input indirectly pulling in
> nss, which has a very time consuming testsuite.
>
> * gnu/packages/gettext.scm (po4a-minimal): New variable.
>
> Change-Id: If8d46a18a02e57d5427852e8e122de01f970ded4

[...]

> +(define-public po4a-minimal
> +  (package/inherit po4a
> +    (native-inputs
> +     ;; Remove test dependencies

Maybe add: “, primarily to reduce the size of the dependency graph of the
‘guix’ package.”

> +     (modify-inputs (package-native-inputs po4a)
> +       (delete "docbook-xml")
> +       (delete "perl-test-pod")
> +       (delete "texlive-updmap.cfg")))

This can be: (delete "docbook-xml" "perl-test-pod" "texlive-updmap.cfg").

Otherwise LGTM!

Ludo’.
Christopher Baines May 9, 2024, 2:36 p.m. UTC | #2
Ludovic Courtès <ludo@gnu.org> writes:

> Christopher Baines <mail@cbaines.net> skribis:
>
>> The main reason is to avoid the texlive-updmap.cfg input indirectly pulling in
>> nss, which has a very time consuming testsuite.
>>
>> * gnu/packages/gettext.scm (po4a-minimal): New variable.
>>
>> Change-Id: If8d46a18a02e57d5427852e8e122de01f970ded4
>
> [...]
>
>> +(define-public po4a-minimal
>> +  (package/inherit po4a
>> +    (native-inputs
>> +     ;; Remove test dependencies
>
> Maybe add: “, primarily to reduce the size of the dependency graph of the
> ‘guix’ package.”
>
>> +     (modify-inputs (package-native-inputs po4a)
>> +       (delete "docbook-xml")
>> +       (delete "perl-test-pod")
>> +       (delete "texlive-updmap.cfg")))
>
> This can be: (delete "docbook-xml" "perl-test-pod" "texlive-updmap.cfg").

I've sent a v3 with these changes now.

Thanks,

Chris
diff mbox series

Patch

diff --git a/gnu/packages/gettext.scm b/gnu/packages/gettext.scm
index 1408cc4cb4..27212e3574 100644
--- a/gnu/packages/gettext.scm
+++ b/gnu/packages/gettext.scm
@@ -317,3 +317,16 @@  (define-public po4a
 more interestingly, the maintenance of translations) using gettext tools on
 areas where they were not expected like documentation.")
     (license gpl2+)))
+
+(define-public po4a-minimal
+  (package/inherit po4a
+    (native-inputs
+     ;; Remove test dependencies
+     (modify-inputs (package-native-inputs po4a)
+       (delete "docbook-xml")
+       (delete "perl-test-pod")
+       (delete "texlive-updmap.cfg")))
+    (arguments
+     (substitute-keyword-arguments (package-arguments po4a)
+       ((#:tests? _ #t) #f)))
+    (properties '((hidden? . #t)))))