diff mbox series

[bug#70693,v2,1/3] gnu: nss/fixed: Tweak performance test.

Message ID 86386e3f8cd94c44ac685abb9b722d746d22177a.1715111123.git.mail@cbaines.net
State New
Headers show
Series [bug#70693,v2,1/3] gnu: nss/fixed: Tweak performance test. | expand

Commit Message

Christopher Baines May 7, 2024, 7:45 p.m. UTC
As I'm seeing this test fail with results of 5 to 7 seconds.

* gnu/packages/nss.scm (nss/fixed)[arguments]: Tweak a test to have a higher
time threshold.

Change-Id: Icb0551cd986acf67b2ba17dc8772a67b9747d31a
---
 gnu/packages/nss.scm | 8 ++++++++
 1 file changed, 8 insertions(+)


base-commit: 014875b29e68da6357a5323e6dd1eaa74a05b753
diff mbox series

Patch

diff --git a/gnu/packages/nss.scm b/gnu/packages/nss.scm
index 162e748094..80bf627583 100644
--- a/gnu/packages/nss.scm
+++ b/gnu/packages/nss.scm
@@ -280,6 +280,14 @@  (define-public nss/fixed
                          (setenv "USE_IP" "TRUE")
                          (setenv "IP_ADDRESS" "127.0.0.1")
 
+                         ;; This specific test is looking at performance "now
+                         ;; verify that we can quickly dump a database", and
+                         ;; we're not testing performance here (especially
+                         ;; since we're using faketime), so raise the
+                         ;; threshold
+                         (substitute* "nss/tests/dbtests/dbtests.sh"
+                           ((" -lt 5") " -lt 50"))
+
                          ;; The "PayPalEE.cert" certificate expires every six months,
                          ;; leading to test failures:
                          ;; <https://bugzilla.mozilla.org/show_bug.cgi?id=609734>.  To