diff mbox series

[bug#42281] gnu: Add python-buku.

Message ID bd6a71b8e9a68016b6eedbed96a39fa06bf6ed07.camel@zrythm.org
State Accepted
Headers show
Series [bug#42281] gnu: Add python-buku. | expand

Commit Message

Alexandros Theodotou Sept. 10, 2020, 3:57 p.m. UTC
Hi Marius,

On Tue, 2020-07-21 at 00:29 +0200, Marius Bakke wrote:
> As this seems like a general-purpose tool and not a Python library,
> it
> would be good to place this elsewhere.  I'm not sure where though,
> maybe
> (gnu packages web)?
> 
> Also I think the 'python-' prefix can be removed.

Done.

> > +    (arguments
> > +      `(#:tests? #f)) ; needs python-mypy-extensions which fails
> > to build
> 
> Actually python-mypy-extensions seems to not be in Guix at all.  Can
> you
> adjust the comment with a TODO?

Done.

> 
> > +    (propagated-inputs
> > +      `(("python-html5lib" ,python-html5lib)
> > +        ("python-urllib3" ,python-urllib3)
> > +        ("python-beautifulsoup4" ,python-beautifulsoup4)
> > +        ("python-pytest" ,python-pytest)
> > +        ("python-pytest-cov" ,python-pytest-cov)
> > +        ("python-pylint" ,python-pylint)
> > +        ("python-vcrpy" ,python-vcrpy)))
> 
> These can probably be regular inputs, as python-build-system will
> automatically 'wrap' the executables with these on PYTHONPATH.

Done.

> 
> > +    (home-page "https://github.com/jarun/buku")
> > +    (synopsis
> > +      "Bookmark manager")
> > +    (description
> > +      "buku is a powerful bookmark manager written in Python3 and
> > SQLite3.")
> 
> It's a chore, but it would be great if you could expand on the
> description.  Something along the lines of "@command{buku} can
> auto-import bookmarks from your browser and present them in an
> interactive command-line interface that lets you compose and update
> bookmarks directly.  It can also present them in a web interface with
> @command{bukuserver}."

Added your proposed text.

> Can you send an updated patch?

Please find the new patch attached.

Thanks,
Alex

Comments

Ludovic Courtès Dec. 18, 2020, 2:02 p.m. UTC | #1
Alexandros Theodotou <alex@zrythm.org> skribis:

> From 217d5661c4d76f79176d947b2376dfa89e5dcc01 Mon Sep 17 00:00:00 2001
> From: Alexandros Theodotou <alex@zrythm.org>
> Date: Thu, 10 Sep 2020 16:54:52 +0100
> Subject: [PATCH] gnu: Add buku.
>
> * gnu/packages/web.scm (buku): New variable.

Applied in 26f6bd0403ed20c1d26eca9d4f28a0da519a56ac, closing!

Ludo’.
diff mbox series

Patch

From 217d5661c4d76f79176d947b2376dfa89e5dcc01 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Thu, 10 Sep 2020 16:54:52 +0100
Subject: [PATCH] gnu: Add buku.

* gnu/packages/web.scm (buku): New variable.
---
 gnu/packages/web.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)

diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 2c3a007779..cf4f1ef0b1 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -7424,6 +7424,40 @@  update an existing mirrored site, and resume interrupted downloads.
 HTTrack is fully configurable, and has an integrated help system.")
     (license license:gpl3+)))
 
+(define-public buku
+  (package
+    (name "buku")
+    (version "4.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "buku" version))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "1g1xhdskfn72xaraqzz2v8dl2iza7bzfpn17z2wdrzkq3ih7yvgg"))))
+    (build-system python-build-system)
+    (arguments
+      `(#:tests? #f)) ; TODO needs python-mypy-extensions
+    (inputs
+      `(("python-html5lib" ,python-html5lib)
+        ("python-urllib3" ,python-urllib3)
+        ("python-beautifulsoup4" ,python-beautifulsoup4)
+        ("python-pytest" ,python-pytest)
+        ("python-pytest-cov" ,python-pytest-cov)
+        ("python-pylint" ,python-pylint)
+        ("python-vcrpy" ,python-vcrpy)))
+    (home-page "https://github.com/jarun/buku")
+    (synopsis
+      "Bookmark manager")
+    (description
+      "buku is a powerful bookmark manager written in Python3 and SQLite3.
+@command{buku} can auto-import bookmarks from your browser and present them
+in an interactive command-line interface that lets you compose and update
+bookmarks directly.  It can also present them in a web interface with
+@command{bukuserver}.")
+    (license license:gpl3+)))
+
 (define-public anonip
   (package
     (name "anonip")
-- 
2.27.0