diff mbox series

[bug#68829,3/3] gnu: Add git-sizer.

Message ID ba86d4c5c7758c78df4667b3bb3163f5b25e2e5e.1706645122.git.code@greghogan.com
State New
Headers show
Series Add git-sizer. | expand

Commit Message

Greg Hogan Jan. 30, 2024, 8:08 p.m. UTC
* gnu/packages/version-control.scm (git-sizer): New variable.

Change-Id: I82a61e364782dabfd59d0e81ff310fa916b5ff23
---
 gnu/packages/version-control.scm | 48 ++++++++++++++++++++++++++++++++
 1 file changed, 48 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index bed4c65c0a..33f9d87f34 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -4000,3 +4000,51 @@  (define-public commit-patch
 comes as a command line app and also an Emacs interface.")
     (home-page "https://porkrind.org/commit-patch/")
     (license license:gpl2+)))
+
+(define-public git-sizer
+  (package
+    (name "git-sizer")
+    (version "1.5.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/github/git-sizer")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1b4sl4djnfaxwph41y4bh9yal4bpd1nz4403ryp7nzna7h2x0zis"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/github/git-sizer"
+       #:install-source? #f
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'fix-paths
+           (lambda* (#:key outputs #:allow-other-keys)
+             (substitute* '("src/github.com/github/git-sizer/git_sizer_test.go")
+               (("bin/git-sizer")
+                (string-append (assoc-ref outputs "out")
+                               "/bin/git-sizer")))))
+         (replace 'check
+           (lambda* (#:key import-path #:allow-other-keys)
+             (for-each (lambda (test)
+                         (invoke "go" "test" "-v" "-run" test import-path))
+                       ;; TestExec and TestSubmodule require a copy of the Git repository.
+                       '("TestBomb" "TestFromSubdir" "TestRefgroups"
+                         "TestRefSelections" "TestTaggedTags")))))))
+    (native-inputs (list git))
+    (propagated-inputs
+     (list go-github-com-cli-safeexec
+           go-github-com-davecgh-go-spew
+           go-github-com-pmezard-go-difflib
+           go-github-com-spf13-pflag
+           go-github-com-stretchr-testify
+           go-go-uber-org-goleak
+           go-golang-org-x-sync
+           go-gopkg-in-yaml-v3))
+    (home-page "https://github.com/github/git-sizer")
+    (synopsis "Analyze size of a Git repo")
+    (description "Compute various size metrics for a Git repository, flagging
+those that might cause problems or inconvenience.")
+    (license license:expat)))