diff mbox series

[bug#68829,2/3] gnu: Add go-go-uber-org-goleak.

Message ID 178b0413c106ab83a88ae2cc7511ac1b160c7623.1706645122.git.code@greghogan.com
State New
Headers show
Series Add git-sizer. | expand

Commit Message

Greg Hogan Jan. 30, 2024, 8:08 p.m. UTC
* gnu/packages/golang.scm (go-go-uber-org-goleak): New variable.

Change-Id: I4dd8f244c44ced8910752f67b318c4e39d5acd74
---
 gnu/packages/golang.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 8b62e9088a..e5b8597e01 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9946,6 +9946,38 @@  (define-public go-git-sr-ht-sircmpwn-getopt
 @code{getopt} for Go.")
     (license license:bsd-3)))
 
+(define-public go-go-uber-org-goleak
+  (package
+    (name "go-go-uber-org-goleak")
+    (version "1.2.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/uber-go/goleak")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1lpqw7ygffak8qki9i4vw8b99l25l8jrw8iwcplqsclk6fzkl24p"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:tests? #f
+       #:import-path "go.uber.org/goleak"))
+    (propagated-inputs
+     (list go-github-com-davecgh-go-spew
+           go-github-com-kr-pretty
+           go-github-com-pmezard-go-difflib
+           go-github-com-stretchr-testify
+           go-golang-org-x-lint
+           go-golang-org-x-tools
+           go-gopkg-in-check-v1
+           go-gopkg-in-yaml-v3))
+    (home-page "https://go.uber.org/goleak")
+    (synopsis "Goroutine leak detector")
+    (description "Go package to verify that there are no unexpected goroutines
+running at the end of a test.")
+    (license license:expat)))
+
 (define-public go-go-uber-org-atomic
   (package
     (name "go-go-uber-org-atomic")