diff mbox series

[bug#67114,10/14] gnu: Add emacs-debase.

Message ID b35b0d7dab4fcbe497439068be5afce5b152af30.1699740282.git.ian@retrospec.tv
State New
Headers show
Series [bug#67114,01/14] gnu: Add emacs-dnt. | expand

Commit Message

Ian Eure Nov. 11, 2023, 10:38 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-debase): New variable.

Change-Id: Idab93a2e2f0834b041792beb41790c725be1e16d
---
 gnu/packages/emacs-xyz.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

Comments

Liliana Marie Prikler Nov. 12, 2023, 7:32 a.m. UTC | #1
Am Samstag, dem 11.11.2023 um 14:38 -0800 schrieb Ian Eure:
> * gnu/packages/emacs-xyz.scm (emacs-debase): New variable.
> 
> Change-Id: Idab93a2e2f0834b041792beb41790c725be1e16d
> ---
>  gnu/packages/emacs-xyz.scm | 28 ++++++++++++++++++++++++++++
>  1 file changed, 28 insertions(+)
> 
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index 9bf806f470..a36852ccdc 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -34903,6 +34903,34 @@ (define-public emacs-helm-linux-disks
>        (home-page "https://github.com/Akirak/helm-linux-disks")
>        (license license:gpl3+))))
>  
> +(define-public emacs-debase
> +  (let ((commit "0b6fc2af3440d68798e3a85d4c889341aae07936")
> +        (version "0.7")
> +        (revision "1"))
> +    (package
> +      (name "emacs-debase")
> +      (version (git-version version revision commit))
> +      (source
> +       (origin
> +         (method git-fetch)
> +         (uri (git-reference
> +               (url
> "https://codeberg.org/emacs-weirdware/debase.git")
> +               (commit commit)))
> +         (file-name (git-file-name name version))
> +         (sha256
> +          (base32
> "112vk1svnc6516vhs47sx5jw6bg8lwrc15l99dxj0sc313lxjy3k"))))
> +
> +      (build-system emacs-build-system)
> +      (inputs (list))
> +      (home-page "https://codeberg.org/emacs-weirdware/debase")
> +      (synopsis "D-Bus convenience layer for Emacs")
> +      (description
> +       "Debase frees you from writing repetitive, annoying
> +boilerplate code to drive D-Bus services by throwing another pile of
> +abstraction at the problem, in the form of unreadably dense, macro-
> heavy,
> +profoundly cursed Lisp.")
Less ad-speak please :)
> +      (license (list license:gpl3+)))))
> +
>  (define-public emacs-psession
>    (let ((commit "3e97267c92b164584e06a6c70ee7491714c7c12c")
>          (revision "1"))
Ian Eure Nov. 12, 2023, 6:01 p.m. UTC | #2
Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

> Am Samstag, dem 11.11.2023 um 14:38 -0800 schrieb Ian Eure:
>> * gnu/packages/emacs-xyz.scm (emacs-debase): New variable.
>> 
>> Change-Id: Idab93a2e2f0834b041792beb41790c725be1e16d
>> ---
>>  gnu/packages/emacs-xyz.scm | 28 ++++++++++++++++++++++++++++
>>  1 file changed, 28 insertions(+)
>> 
>> diff --git a/gnu/packages/emacs-xyz.scm 
>> b/gnu/packages/emacs-xyz.scm
>> index 9bf806f470..a36852ccdc 100644
>> --- a/gnu/packages/emacs-xyz.scm
>> +++ b/gnu/packages/emacs-xyz.scm
>> @@ -34903,6 +34903,34 @@ (define-public emacs-helm-linux-disks
>>        (home-page "https://github.com/Akirak/helm-linux-disks")
>>        (license license:gpl3+))))
>>  
>> +(define-public emacs-debase
>> +  (let ((commit "0b6fc2af3440d68798e3a85d4c889341aae07936")
>> +        (version "0.7")
>> +        (revision "1"))
>> +    (package
>> +      (name "emacs-debase")
>> +      (version (git-version version revision commit))
>> +      (source
>> +       (origin
>> +         (method git-fetch)
>> +         (uri (git-reference
>> +               (url
>> "https://codeberg.org/emacs-weirdware/debase.git")
>> +               (commit commit)))
>> +         (file-name (git-file-name name version))
>> +         (sha256
>> +          (base32
>> "112vk1svnc6516vhs47sx5jw6bg8lwrc15l99dxj0sc313lxjy3k"))))
>> +
>> +      (build-system emacs-build-system)
>> +      (inputs (list))
>> +      (home-page 
>> "https://codeberg.org/emacs-weirdware/debase")
>> +      (synopsis "D-Bus convenience layer for Emacs")
>> +      (description
>> +       "Debase frees you from writing repetitive, annoying
>> +boilerplate code to drive D-Bus services by throwing another 
>> pile of
>> +abstraction at the problem, in the form of unreadably dense, 
>> macro-
>> heavy,
>> +profoundly cursed Lisp.")
> Less ad-speak please :)

I’ll make the change, but I dislike this feedback.  The 
description is tongue-in-cheek, because the situation with D-Bus 
is comically ridiculous, and this kind of 
whistling-past-the-graveyard humor suffuses much of my work.

Thanks,

  -- Ian
Liliana Marie Prikler Nov. 13, 2023, 6:18 p.m. UTC | #3
Am Sonntag, dem 12.11.2023 um 10:01 -0800 schrieb Ian Eure:
> 
> Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
> 
> > Am Samstag, dem 11.11.2023 um 14:38 -0800 schrieb Ian Eure:
> > > * gnu/packages/emacs-xyz.scm (emacs-debase): New variable.
> > > 
> > > Change-Id: Idab93a2e2f0834b041792beb41790c725be1e16d
> > > ---
> > >  gnu/packages/emacs-xyz.scm | 28 ++++++++++++++++++++++++++++
> > >  1 file changed, 28 insertions(+)
> > > 
> > > diff --git a/gnu/packages/emacs-xyz.scm 
> > > b/gnu/packages/emacs-xyz.scm
> > > index 9bf806f470..a36852ccdc 100644
> > > --- a/gnu/packages/emacs-xyz.scm
> > > +++ b/gnu/packages/emacs-xyz.scm
> > > @@ -34903,6 +34903,34 @@ (define-public emacs-helm-linux-disks
> > >        (home-page "https://github.com/Akirak/helm-linux-disks")
> > >        (license license:gpl3+))))
> > >  
> > > +(define-public emacs-debase
> > > +  (let ((commit "0b6fc2af3440d68798e3a85d4c889341aae07936")
> > > +        (version "0.7")
> > > +        (revision "1"))
> > > +    (package
> > > +      (name "emacs-debase")
> > > +      (version (git-version version revision commit))
> > > +      (source
> > > +       (origin
> > > +         (method git-fetch)
> > > +         (uri (git-reference
> > > +               (url
> > > "https://codeberg.org/emacs-weirdware/debase.git")
> > > +               (commit commit)))
> > > +         (file-name (git-file-name name version))
> > > +         (sha256
> > > +          (base32
> > > "112vk1svnc6516vhs47sx5jw6bg8lwrc15l99dxj0sc313lxjy3k"))))
> > > +
> > > +      (build-system emacs-build-system)
> > > +      (inputs (list))
> > > +      (home-page 
> > > "https://codeberg.org/emacs-weirdware/debase")
> > > +      (synopsis "D-Bus convenience layer for Emacs")
> > > +      (description
> > > +       "Debase frees you from writing repetitive, annoying
> > > +boilerplate code to drive D-Bus services by throwing another 
> > > pile of
> > > +abstraction at the problem, in the form of unreadably dense, 
> > > macro-
> > > heavy,
> > > +profoundly cursed Lisp.")
> > Less ad-speak please :)
> 
> I’ll make the change, but I dislike this feedback.  The 
> description is tongue-in-cheek, because the situation with D-Bus 
> is comically ridiculous
You may not like it, but the purpose of a description in Guix is to
describe software objectively.  Your opinion on the merits or lack
thereof of dbus is merely that: an opinion.  With no facts or citations
from other sources to back up your claim that the situation is
"comically ridiculous", I shall simply file it under "highly subjective
stuff I read on the Internet once". 

> [T]his kind of whistling-past-the-graveyard humor suffuses much of my
> work.
Yeah, I agree that that's perhaps not the best starting point for
writing actually informative descriptions.  C'est la vie.  As a matter
of fact, you're not the first one whom I ask to revise their
description because upstream did a bad job; though on the top of my
head I can not recall whether you're the first upstream developer to do
so.  In any case, I simply ask you to tone it down and stick to the
facts – as far as I can see, debase appears to be an ORM for dbus in
Emacs.  Let's start from there and see where we land :)

Cheers
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 9bf806f470..a36852ccdc 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -34903,6 +34903,34 @@  (define-public emacs-helm-linux-disks
       (home-page "https://github.com/Akirak/helm-linux-disks")
       (license license:gpl3+))))
 
+(define-public emacs-debase
+  (let ((commit "0b6fc2af3440d68798e3a85d4c889341aae07936")
+        (version "0.7")
+        (revision "1"))
+    (package
+      (name "emacs-debase")
+      (version (git-version version revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://codeberg.org/emacs-weirdware/debase.git")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "112vk1svnc6516vhs47sx5jw6bg8lwrc15l99dxj0sc313lxjy3k"))))
+
+      (build-system emacs-build-system)
+      (inputs (list))
+      (home-page "https://codeberg.org/emacs-weirdware/debase")
+      (synopsis "D-Bus convenience layer for Emacs")
+      (description
+       "Debase frees you from writing repetitive, annoying
+boilerplate code to drive D-Bus services by throwing another pile of
+abstraction at the problem, in the form of unreadably dense, macro-heavy,
+profoundly cursed Lisp.")
+      (license (list license:gpl3+)))))
+
 (define-public emacs-psession
   (let ((commit "3e97267c92b164584e06a6c70ee7491714c7c12c")
         (revision "1"))