diff mbox series

[bug#67114,01/14] gnu: Add emacs-dnt.

Message ID 38d6463959d226a7cf587410063f9c3878d2305f.1699740282.git.ian@retrospec.tv
State New
Headers show
Series [bug#67114,01/14] gnu: Add emacs-dnt. | expand

Commit Message

Ian Eure Nov. 11, 2023, 10:38 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-dnt): New variable.
---
 gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

Comments

Liliana Marie Prikler Nov. 12, 2023, 7:28 a.m. UTC | #1
Am Samstag, dem 11.11.2023 um 20:16 -0800 schrieb Ian Eure:
> * gnu/packages/emacs-xyz.scm (emacs-dnt): New variable.
> ---
Hi, you've sent this to the wrong bug number.  Please resend the actual
67120 as v2 so we can ignore this blunder :)
Liliana Marie Prikler Nov. 12, 2023, 7:29 a.m. UTC | #2
Am Samstag, dem 11.11.2023 um 14:38 -0800 schrieb Ian Eure:
> * gnu/packages/emacs-xyz.scm (emacs-dnt): New variable.
> ---
>  gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
>  1 file changed, 25 insertions(+)
> 
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index 1319c353cb..4648432441 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -135,6 +135,7 @@
>  ;;; Copyright © 2023 Sergiu Ivanov <sivanov@colimite.fr>
>  ;;; Copyright © 2023 Camilo Q.S. (Distopico) <distopico@riseup.net>
>  ;;; Copyright © 2023 Thanos Apollo <public@thanosapollo.com>
> +;;; Copyright © 2023 Ian Eure <ian@retrospec.tv>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -3294,6 +3295,30 @@ (define-public emacs-eww-lnum
>  incrementally confined in Isearch manner.")
>      (license license:gpl3+)))
>  
> +(define-public emacs-dnt
> +  (let ((commit "d28d232d682094ab79cfa78c97668c6ebd327c8c")
> +        (version "0.0.1")
> +        (revision "1"))
> +    (package
> +      (name "emacs-dnt")
> +      (version (git-version version revision commit))
It's better to inline the base version.
> +      (source
> +       (origin
> +         (method git-fetch)
> +         (uri (git-reference
> +               (url "https://codeberg.org/emacs-weirdware/dnt.git")
> +               (commit commit)))
> +         (file-name (git-file-name name version))
> +         (sha256
> +          (base32
> "1bls9j1ibw0npjapslbrh6nmlbn3d4ajhjygsqlf6h9qg12sxm3r"))))
> +      (inputs (list emacs-s))
> +      (build-system emacs-build-system)
> +      (home-page "https://codeberg.org/emacs-weirdware/dnt")
> +      (synopsis "Strip trackers from URLs")
> +      (description "Prevent advertisers from tracking you when you
> open
> +URLs (or listen to podcasts) in Emacs.")
> +      (license (list license:gpl3+)))))
> +
Cheers
Ian Eure Nov. 12, 2023, 5:21 p.m. UTC | #3
Yep, I sure did. :/

Fixed patches incoming.

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

> Am Samstag, dem 11.11.2023 um 20:16 -0800 schrieb Ian Eure:
>> * gnu/packages/emacs-xyz.scm (emacs-dnt): New variable.
>> ---
> Hi, you've sent this to the wrong bug number.  Please resend the 
> actual
> 67120 as v2 so we can ignore this blunder :)
>
Ian Eure Nov. 12, 2023, 6:09 p.m. UTC | #4
Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

> Am Samstag, dem 11.11.2023 um 14:38 -0800 schrieb Ian Eure:
>> * gnu/packages/emacs-xyz.scm (emacs-dnt): New variable.
>> ---
>>  gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
>>  1 file changed, 25 insertions(+)
>> 
>> diff --git a/gnu/packages/emacs-xyz.scm 
>> b/gnu/packages/emacs-xyz.scm
>> index 1319c353cb..4648432441 100644
>> --- a/gnu/packages/emacs-xyz.scm
>> +++ b/gnu/packages/emacs-xyz.scm
>> @@ -135,6 +135,7 @@
>>  ;;; Copyright © 2023 Sergiu Ivanov <sivanov@colimite.fr>
>>  ;;; Copyright © 2023 Camilo Q.S. (Distopico) 
>> <distopico@riseup.net>
>>  ;;; Copyright © 2023 Thanos Apollo <public@thanosapollo.com>
>> +;;; Copyright © 2023 Ian Eure <ian@retrospec.tv>
>>  ;;;
>>  ;;; This file is part of GNU Guix.
>>  ;;;
>> @@ -3294,6 +3295,30 @@ (define-public emacs-eww-lnum
>>  incrementally confined in Isearch manner.")
>>      (license license:gpl3+)))
>>  
>> +(define-public emacs-dnt
>> +  (let ((commit "d28d232d682094ab79cfa78c97668c6ebd327c8c")
>> +        (version "0.0.1")
>> +        (revision "1"))
>> +    (package
>> +      (name "emacs-dnt")
>> +      (version (git-version version revision commit))
> It's better to inline the base version.

Why?  As a new contributor, I’m genuinely curious.

I let-bound it because:

- In the info manual for Guix, two out of three were already.
- You’ll need to update the commit and version at the same time in 
  many cases, so having them next to each other seems convenient.
- The variable names make it more obvious if arguments to 
  git-version get swapped around.

Thanks,

  -- Ian
Liliana Marie Prikler Nov. 12, 2023, 9:42 p.m. UTC | #5
Am Sonntag, dem 12.11.2023 um 10:09 -0800 schrieb Ian Eure:
> 
> Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
> 
> > Am Samstag, dem 11.11.2023 um 14:38 -0800 schrieb Ian Eure:
> > > * gnu/packages/emacs-xyz.scm (emacs-dnt): New variable.
> > > ---
> > >  gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
> > >  1 file changed, 25 insertions(+)
> > > 
> > > diff --git a/gnu/packages/emacs-xyz.scm 
> > > b/gnu/packages/emacs-xyz.scm
> > > index 1319c353cb..4648432441 100644
> > > --- a/gnu/packages/emacs-xyz.scm
> > > +++ b/gnu/packages/emacs-xyz.scm
> > > @@ -135,6 +135,7 @@
> > >  ;;; Copyright © 2023 Sergiu Ivanov <sivanov@colimite.fr>
> > >  ;;; Copyright © 2023 Camilo Q.S. (Distopico) 
> > > <distopico@riseup.net>
> > >  ;;; Copyright © 2023 Thanos Apollo <public@thanosapollo.com>
> > > +;;; Copyright © 2023 Ian Eure <ian@retrospec.tv>
> > >  ;;;
> > >  ;;; This file is part of GNU Guix.
> > >  ;;;
> > > @@ -3294,6 +3295,30 @@ (define-public emacs-eww-lnum
> > >  incrementally confined in Isearch manner.")
> > >      (license license:gpl3+)))
> > >  
> > > +(define-public emacs-dnt
> > > +  (let ((commit "d28d232d682094ab79cfa78c97668c6ebd327c8c")
> > > +        (version "0.0.1")
> > > +        (revision "1"))
> > > +    (package
> > > +      (name "emacs-dnt")
> > > +      (version (git-version version revision commit))
> > It's better to inline the base version.
> 
> Why?  As a new contributor, I’m genuinely curious.
> 
> I let-bound it because:
> 
> - In the info manual for Guix, two out of three were already.
> - You’ll need to update the commit and version at the same time in 
>   many cases, so having them next to each other seems convenient.
> - The variable names make it more obvious if arguments to 
>   git-version get swapped around.
You are introducing a gratuitous line, plus making room for confusion
between the let-bound version and the syntax-introduced one.  The
benefit of having "one less place" more often than not doesn't even
save you a hunk, whereas in the preferred case for Guix where we'd use
actual versions, you'd have to reindent the whole package anyways.

Cheer
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 1319c353cb..4648432441 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -135,6 +135,7 @@ 
 ;;; Copyright © 2023 Sergiu Ivanov <sivanov@colimite.fr>
 ;;; Copyright © 2023 Camilo Q.S. (Distopico) <distopico@riseup.net>
 ;;; Copyright © 2023 Thanos Apollo <public@thanosapollo.com>
+;;; Copyright © 2023 Ian Eure <ian@retrospec.tv>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -3294,6 +3295,30 @@  (define-public emacs-eww-lnum
 incrementally confined in Isearch manner.")
     (license license:gpl3+)))
 
+(define-public emacs-dnt
+  (let ((commit "d28d232d682094ab79cfa78c97668c6ebd327c8c")
+        (version "0.0.1")
+        (revision "1"))
+    (package
+      (name "emacs-dnt")
+      (version (git-version version revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://codeberg.org/emacs-weirdware/dnt.git")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1bls9j1ibw0npjapslbrh6nmlbn3d4ajhjygsqlf6h9qg12sxm3r"))))
+      (inputs (list emacs-s))
+      (build-system emacs-build-system)
+      (home-page "https://codeberg.org/emacs-weirdware/dnt")
+      (synopsis "Strip trackers from URLs")
+      (description "Prevent advertisers from tracking you when you open
+URLs (or listen to podcasts) in Emacs.")
+      (license (list license:gpl3+)))))
+
 
 
 ;;;