diff mbox series

[bug#49101,v3,3/6] gnu: ocaml4.07-pcre: Remove package.

Message ID af0b5f02c198c135ab5322bb706bf9191c789682.1624117491.git.public@yoctocell.xyz
State Accepted
Headers show
Series Add ocaml-mparser & friends | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Xinglu Chen June 19, 2021, 3:50 p.m. UTC
* gnu/packages/ocaml.scm (ocaml4.07-pcre): Remove package.  It has been
superseded by ‘ocaml-pcre’.
---
 gnu/packages/ocaml.scm | 30 ------------------------------
 1 file changed, 30 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index d3674ccba8..c89908a1b2 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3118,36 +3118,6 @@  offered by the Perl language.")
     ;; With static linking exception
     (license license:lgpl2.1+)))
 
-(define-public ocaml4.07-pcre
-  (package
-    (name "ocaml4.07-pcre")
-    (version "7.4.1")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                     (url "https://github.com/mmottl/pcre-ocaml")
-                     (commit version)))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "11sd8g668h48790lamz0riw9jgnfkaif5qdfa0akcndwa6aj07jf"))))
-    (build-system dune-build-system)
-    (arguments
-     `(#:test-target "."
-       #:ocaml ,ocaml-4.07
-       #:findlib ,ocaml4.07-findlib
-       #:dune ,ocaml4.07-dune))
-    (native-inputs
-     `(("ocaml-base" ,(package-with-ocaml4.07 ocaml-base))
-       ("pcre:bin" ,pcre "bin")))
-    (propagated-inputs `(("pcre" ,pcre)))
-    (home-page "https://mmottl.github.io/pcre-ocaml")
-    (synopsis "Bindings to the Perl Compatibility Regular Expressions library")
-    (description "Pcre-ocaml offers library functions for string pattern
-matching and substitution, similar to the functionality offered by the Perl
-language.")
-    (license license:lgpl2.1+))); with the OCaml link exception
-
 (define-public ocaml-expect
   (package
     (name "ocaml-expect")