diff mbox series

[bug#49101,v3,1/6] gnu: Add ocaml-pcre.

Message ID 6e05031b1aa80953a2dda53017957e06d66c333c.1624117491.git.public@yoctocell.xyz
State Accepted
Headers show
Series Add ocaml-mparser & friends | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Xinglu Chen June 19, 2021, 3:50 p.m. UTC
* gnu/packages/ocaml.scm (ocaml-pcre): New variable.
---
 gnu/packages/ocaml.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index a8432ebbfe..542730699e 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3086,6 +3086,38 @@  every compliant installation of OCaml and organize these libraries into a
 hierarchy of modules.")
     (license license:lgpl2.1+)))
 
+(define-public ocaml-pcre
+  (package
+    (name "ocaml-pcre")
+    (version "7.4.6")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+              (url "https://github.com/mmottl/pcre-ocaml")
+              (commit version)))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32
+            "11mck879p5zvkghps4ky8yslm0isgz52d84adl0dmcfxv2ibvcym"))))
+    (build-system dune-build-system)
+    (arguments
+     ;; No tests.
+     '(#:tests? #f))
+    (propagated-inputs
+     `(("dune-configurator" ,dune-configurator)
+       ("pcre" ,pcre)))
+    (native-inputs
+     `(("pcre:bin" ,pcre "bin")))
+    (home-page "https://mmottl.github.io/pcre-ocaml")
+    (synopsis
+      "Bindings to the Perl Compatibility Regular Expressions library")
+    (description "pcre-ocaml offers library functions for string
+pattern matching and substitution, similar to the functionality
+offered by the Perl language.")
+    ;; With static linking exception
+    (license license:lgpl2.1+)))
+
 (define-public ocaml4.07-pcre
   (package
     (name "ocaml4.07-pcre")