diff mbox series

[bug#66453,1/4] gnu: kicad: Add 3rdparty search path.

Message ID ada8e734a559ce1bd207c3c455148ad229b22ef0.1696967309.git.peter@polidoro.io
State New
Headers show
Series Three KiCad color themes | expand

Commit Message

Peter Polidoro Oct. 10, 2023, 8:05 p.m. UTC
From: Peter Polidoro <peter@polidoro.io>

* gnu/packages/engineering.scm (kicad): Add 3rdparty search path.
---
 gnu/packages/engineering.scm | 9 ++++++++-
 1 file changed, 8 insertions(+), 1 deletion(-)

Comments

Steve George March 5, 2024, 12:47 p.m. UTC | #1
Hi,

Were you ever able to resolve the directory to use for these themes?

If not, is there another option, or should we close :-(

Thanks,

Steve


On 10 Oct, peter@polidoro.io wrote:
> From: Peter Polidoro <peter@polidoro.io>
> 
> * gnu/packages/engineering.scm (kicad): Add 3rdparty search path.
> ---
>  gnu/packages/engineering.scm | 9 ++++++++-
>  1 file changed, 8 insertions(+), 1 deletion(-)
> 
> diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
> index c9aec482da..cad419ef70 100644
> --- a/gnu/packages/engineering.scm
> +++ b/gnu/packages/engineering.scm
> @@ -1155,7 +1155,14 @@ (define-public kicad
>              (files '("share/kicad/footprints")))
>             (search-path-specification
>              (variable "KICAD7_3DMODEL_DIR")
> -            (files '("share/kicad/3dmodels")))))
> +            (files '("share/kicad/3dmodels")))
> +           ;; Using the following environment variable removes write access to
> +           ;; the KiCad Plugin and Content Manager directory so using any Guix
> +           ;; plugin or color theme packages requires all plugin or color
> +           ;; themes to be installed using Guix packages
> +           (search-path-specification
> +            (variable "KICAD7_3RD_PARTY")
> +            (files '("share/kicad/3rdparty")))))
>      (native-inputs (list boost
>                           desktop-file-utils
>                           gettext-minimal
> -- 
> 2.41.0
> 
> 
> 
>
Peter Polidoro March 5, 2024, 3:47 p.m. UTC | #2
This is still an open issue on the KiCad repository.

I have been told it is an easy feature for them to add and I was 
hoping it would be included in KiCad 8, but it has not been 
included yet.

You can close this for now and then I can resubmit someday if they 
ever get around to adding the new environment variable. Thanks!

https://gitlab.com/kicad/code/kicad/-/issues/15687

Steve George <steve@futurile.net> writes:

> Hi,
>
> Were you ever able to resolve the directory to use for these 
> themes?
>
> If not, is there another option, or should we close :-(
>
> Thanks,
>
> Steve
>
>
> On 10 Oct, peter@polidoro.io wrote:
diff mbox series

Patch

diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index c9aec482da..cad419ef70 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -1155,7 +1155,14 @@  (define-public kicad
             (files '("share/kicad/footprints")))
            (search-path-specification
             (variable "KICAD7_3DMODEL_DIR")
-            (files '("share/kicad/3dmodels")))))
+            (files '("share/kicad/3dmodels")))
+           ;; Using the following environment variable removes write access to
+           ;; the KiCad Plugin and Content Manager directory so using any Guix
+           ;; plugin or color theme packages requires all plugin or color
+           ;; themes to be installed using Guix packages
+           (search-path-specification
+            (variable "KICAD7_3RD_PARTY")
+            (files '("share/kicad/3rdparty")))))
     (native-inputs (list boost
                          desktop-file-utils
                          gettext-minimal