diff mbox series

[bug#41293,1/2] gnu: Add granite-6.

Message ID a9e179302a7aedffdb3e9c75242e48ab4a46135b.1694433831.git.altadil@protonmail.com
State New
Headers show
Series [bug#41293,1/2] gnu: Add granite-6. | expand

Commit Message

altadil Sept. 11, 2023, 12:07 p.m. UTC
* gnu/packages/pantheon.scm (granite-6): new variable.

This version will be needed to add some pantheon packages.
More precisely, those still using GTK+ 3.
---
guix build --rounds=2 was successfully run on a Zen4 CPU,
for the following --system= options:
- x86_64-linux
- i686-linux
- aarch64-linux.
 gnu/packages/pantheon.scm | 16 ++++++++++++++++
 1 file changed, 16 insertions(+)


base-commit: 2eb6df537c36da8bf8e81ff698421f6fb1bfd1ab
diff mbox series

Patch

diff --git a/gnu/packages/pantheon.scm b/gnu/packages/pantheon.scm
index 12892db137..f5b19eb452 100644
--- a/gnu/packages/pantheon.scm
+++ b/gnu/packages/pantheon.scm
@@ -72,6 +72,22 @@  (define-public granite
 in apps built for the Pantheon desktop.")
     (license license:lgpl3+)))
 
+;; This is required for pantheon apps that have not been ported to GTK4 yet.
+(define-public granite-6
+  (package
+    (inherit granite)
+    (version "6.2.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/elementary/granite")
+                    (commit version)))
+              (file-name (git-file-name "granite" version))
+              (sha256
+               (base32
+                "0ilslmg63hh2x7h5rvs3mhzw1y9ixhhkqnn1j1lzwm12v2iidkaq"))))
+    (propagated-inputs (list glib libgee gtk+))))
+
 (define-public pantheon-calculator
   (package
     (name "pantheon-calculator")