[bug#74054,2/3] gnu: plib: Build with -fPIC.
Commit Message
* gnu/packages/game-development.scm (plib) [configure-flags]: New argument.
[inputs]: Move field after...
[native-inputs]: ... this one.
Change-Id: Ieddfb8814632f74c98d0e2cda949709b718c7a0d
---
gnu/packages/game-development.scm | 10 ++++++----
1 file changed, 6 insertions(+), 4 deletions(-)
@@ -2573,10 +2573,12 @@ (define-public plib
(patches (search-patches "plib-CVE-2011-4620.patch"
"plib-CVE-2012-4552.patch"))))
(build-system gnu-build-system)
- (inputs
- (list mesa libxi libxmu))
- (native-inputs
- (list pkg-config))
+ ;; plib exists only as a static library, per the author's choice (see:
+ ;; https://sourceforge.net/p/plib/mailman/message/10289018/). Build it
+ ;; with PIC, so that shared programs can at least "link" to it.
+ (arguments (list #:configure-flags #~(list "CXXFLAGS=-fPIC")))
+ (native-inputs (list autoconf automake pkg-config))
+ (inputs (list mesa libxi libxmu))
(home-page "https://plib.sourceforge.net/")
(synopsis "Suite of portable game libraries")
(description "PLIB is a set of libraries that will permit programmers to