diff mbox series

[bug#68199,2/3] gnu: taisei: Use gexps.

Message ID a7725414f3a4bcee172c99cfc42f8ede821e1807.1704112246.git.gemmaro.dev@gmail.com
State New
Headers show
Series gnu: taisei: Update to 1.4. | expand

Commit Message

gemmaro Jan. 2, 2024, 1:07 a.m. UTC
* gnu/packages/games.scm (taisei)[arguments]: Use gexps.

Change-Id: I0732c0ecca482e5ab2c553b3c2d75e8003a9d781
---
 gnu/packages/games.scm | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)

Comments

Liliana Marie Prikler Jan. 2, 2024, 9:02 p.m. UTC | #1
Am Dienstag, dem 02.01.2024 um 10:07 +0900 schrieb gemmaro:
> * gnu/packages/games.scm (taisei)[arguments]: Use gexps.
> 
> Change-Id: I0732c0ecca482e5ab2c553b3c2d75e8003a9d781
> ---
>  gnu/packages/games.scm | 7 ++++---
>  1 file changed, 4 insertions(+), 3 deletions(-)
> 
> diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
> index c26b9ef2c9..1bfa8e19b8 100644
> --- a/gnu/packages/games.scm
> +++ b/gnu/packages/games.scm
> @@ -3399,9 +3399,10 @@ (define-public taisei
>          (base32
> "1g53fcyrlzmvlsb40pw90gaglysv6n1w42hk263iv61ibhdmzh6v"))))
>      (build-system meson-build-system)
>      (arguments
> -     `(#:build-type "release" ;comment out for bug-reporting (and
> cheats)
> -       #:configure-flags (list "-Dr_default=gles30" "-
> Dr_gles20=true"
> -                               "-Dr_gles30=true" "-
> Dshader_transpiler=true")))
> +     (list
> +      #:build-type "release" ;comment out for bug-reporting (and
> cheats)
> +      #:configure-flags #~(list "-Dr_default=gles30" "-
> Dr_gles20=true"
> +                                "-Dr_gles30=true" "-
> Dshader_transpiler=true")))
>      (native-inputs (list pkg-config python python-docutils python-
> pygments))
>      (inputs (list cglm
>                    freetype
You can (and I argue should) squash this onto the previous restyling
commit.

Cheers
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index c26b9ef2c9..1bfa8e19b8 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -3399,9 +3399,10 @@  (define-public taisei
         (base32 "1g53fcyrlzmvlsb40pw90gaglysv6n1w42hk263iv61ibhdmzh6v"))))
     (build-system meson-build-system)
     (arguments
-     `(#:build-type "release" ;comment out for bug-reporting (and cheats)
-       #:configure-flags (list "-Dr_default=gles30" "-Dr_gles20=true"
-                               "-Dr_gles30=true" "-Dshader_transpiler=true")))
+     (list
+      #:build-type "release" ;comment out for bug-reporting (and cheats)
+      #:configure-flags #~(list "-Dr_default=gles30" "-Dr_gles20=true"
+                                "-Dr_gles30=true" "-Dshader_transpiler=true")))
     (native-inputs (list pkg-config python python-docutils python-pygments))
     (inputs (list cglm
                   freetype