diff mbox series

[bug#68199,1/3] gnu: taisei: Reformat with guix style.

Message ID 1365e301c94d1d7bf36a2985c9ba2f01b22edd05.1704112246.git.gemmaro.dev@gmail.com
State New
Headers show
Series gnu: taisei: Update to 1.4. | expand

Commit Message

gemmaro Jan. 2, 2024, 1:07 a.m. UTC
* gnu/packages/games.scm (taisei): Reformat with guix style.

Change-Id: If542566f43e581968f73537e90101a18d3b1bca1
---
 gnu/packages/games.scm | 56 ++++++++++++++++++++----------------------
 1 file changed, 27 insertions(+), 29 deletions(-)

Comments

Liliana Marie Prikler Jan. 2, 2024, 9:02 p.m. UTC | #1
Am Dienstag, dem 02.01.2024 um 10:07 +0900 schrieb gemmaro:
> * gnu/packages/games.scm (taisei): Reformat with guix style.
> 
> Change-Id: If542566f43e581968f73537e90101a18d3b1bca1
> ---
>  gnu/packages/games.scm | 56 ++++++++++++++++++++--------------------
> --
>  1 file changed, 27 insertions(+), 29 deletions(-)
> 
> diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
> index c7813790a1..c26b9ef2c9 100644
> --- a/gnu/packages/games.scm
> +++ b/gnu/packages/games.scm
> @@ -78,7 +78,7 @@
>  ;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
>  ;;; Copyright © 2023 Florian Pelz <pelzflorian@pelzflorian.de>
>  ;;; Copyright © 2023 Ivana Drazovic <iv.dra@hotmail.com>
> -;;; Copyright © 2023 gemmaro <gemmaro.dev@gmail.com>
> +;;; Copyright © 2023, 2024 gemmaro <gemmaro.dev@gmail.com>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -3390,46 +3390,44 @@ (define-public taisei
>       (origin
>         (method url-fetch)
>         (uri (string-append "https://github.com/taisei-project/"
> -                           "taisei/releases/download/v" version
> -                           "/taisei-v" version ".tar.xz"))
> +                           "taisei/releases/download/v"
> +                           version
> +                           "/taisei-v"
> +                           version
> +                           ".tar.xz"))
>         (sha256
>          (base32
> "1g53fcyrlzmvlsb40pw90gaglysv6n1w42hk263iv61ibhdmzh6v"))))
>      (build-system meson-build-system)
>      (arguments
> -     `(#:build-type "release"      ;comment out for bug-reporting
> (and cheats)
> -       #:configure-flags
> -       (list "-Dr_default=gles30"
> -             "-Dr_gles20=true"
> -             "-Dr_gles30=true"
> -             "-Dshader_transpiler=true")))
> -    (native-inputs
> -     (list pkg-config python python-docutils python-pygments))
> -    (inputs
> -     (list cglm
> -           freetype
> -           libpng
> -           libwebp
> -           libzip
> -           mesa
> -           openssl
> -           opusfile
> -           sdl2
> -           sdl2-mixer
> -           shaderc
> -           spirv-cross
> -           zlib))
> +     `(#:build-type "release" ;comment out for bug-reporting (and
> cheats)
> +       #:configure-flags (list "-Dr_default=gles30" "-
> Dr_gles20=true"
> +                               "-Dr_gles30=true" "-
> Dshader_transpiler=true")))
> +    (native-inputs (list pkg-config python python-docutils python-
> pygments))
> +    (inputs (list cglm
> +                  freetype
> +                  libpng
> +                  libwebp
> +                  libzip
> +                  mesa
> +                  openssl
> +                  opusfile
> +                  sdl2
> +                  sdl2-mixer
> +                  shaderc
> +                  spirv-cross
> +                  zlib))
>      (home-page "https://taisei-project.org/")
>      (synopsis "Shoot'em up fangame and libre clone of Touhou
> Project")
>      (description
>       "The player controls a character (one of three: Good, Bad, and
> Dead),
>  dodges the missiles (lots of it cover the screen, but the
> character's hitbox
>  is very small), and shoot at the adversaries that keep appear on the
> screen.")
> -    (license (list ;;game
> +    (license (list ;game
This comment looks out of place.
>                     license:expat
> -                   ;;resources/00-taisei.pkgdir/bgm/
> -                   ;;atlas/portraits/
> +                   ;; resources/00-taisei.pkgdir/bgm/
> +                   ;; atlas/portraits/
>                     license:cc-by4.0
> -                   ;;miscellaneous
> +                   ;; miscellaneous
>                     license:cc0
>                     license:public-domain))))
>  
Other than that LGTM.
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index c7813790a1..c26b9ef2c9 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -78,7 +78,7 @@ 
 ;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
 ;;; Copyright © 2023 Florian Pelz <pelzflorian@pelzflorian.de>
 ;;; Copyright © 2023 Ivana Drazovic <iv.dra@hotmail.com>
-;;; Copyright © 2023 gemmaro <gemmaro.dev@gmail.com>
+;;; Copyright © 2023, 2024 gemmaro <gemmaro.dev@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -3390,46 +3390,44 @@  (define-public taisei
      (origin
        (method url-fetch)
        (uri (string-append "https://github.com/taisei-project/"
-                           "taisei/releases/download/v" version
-                           "/taisei-v" version ".tar.xz"))
+                           "taisei/releases/download/v"
+                           version
+                           "/taisei-v"
+                           version
+                           ".tar.xz"))
        (sha256
         (base32 "1g53fcyrlzmvlsb40pw90gaglysv6n1w42hk263iv61ibhdmzh6v"))))
     (build-system meson-build-system)
     (arguments
-     `(#:build-type "release"      ;comment out for bug-reporting (and cheats)
-       #:configure-flags
-       (list "-Dr_default=gles30"
-             "-Dr_gles20=true"
-             "-Dr_gles30=true"
-             "-Dshader_transpiler=true")))
-    (native-inputs
-     (list pkg-config python python-docutils python-pygments))
-    (inputs
-     (list cglm
-           freetype
-           libpng
-           libwebp
-           libzip
-           mesa
-           openssl
-           opusfile
-           sdl2
-           sdl2-mixer
-           shaderc
-           spirv-cross
-           zlib))
+     `(#:build-type "release" ;comment out for bug-reporting (and cheats)
+       #:configure-flags (list "-Dr_default=gles30" "-Dr_gles20=true"
+                               "-Dr_gles30=true" "-Dshader_transpiler=true")))
+    (native-inputs (list pkg-config python python-docutils python-pygments))
+    (inputs (list cglm
+                  freetype
+                  libpng
+                  libwebp
+                  libzip
+                  mesa
+                  openssl
+                  opusfile
+                  sdl2
+                  sdl2-mixer
+                  shaderc
+                  spirv-cross
+                  zlib))
     (home-page "https://taisei-project.org/")
     (synopsis "Shoot'em up fangame and libre clone of Touhou Project")
     (description
      "The player controls a character (one of three: Good, Bad, and Dead),
 dodges the missiles (lots of it cover the screen, but the character's hitbox
 is very small), and shoot at the adversaries that keep appear on the screen.")
-    (license (list ;;game
+    (license (list ;game
                    license:expat
-                   ;;resources/00-taisei.pkgdir/bgm/
-                   ;;atlas/portraits/
+                   ;; resources/00-taisei.pkgdir/bgm/
+                   ;; atlas/portraits/
                    license:cc-by4.0
-                   ;;miscellaneous
+                   ;; miscellaneous
                    license:cc0
                    license:public-domain))))