From 70037b0f0f640c64aa2323a0bc8ba85a17c5559e Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Mon, 11 May 2020 01:26:43 -0400
Subject: [PATCH] gnu: font-gnu-unifont: Unify outputs for fonts.
* gnu/package/fonts.scm (font-gnu-unifont): Combine font types.
[arguments]<'install>: Change outputs for pcf and psf to "out".
---
gnu/packages/fonts.scm | 12 +++++-------
1 file changed, 5 insertions(+), 7 deletions(-)
@@ -689,9 +689,7 @@ for use at smaller text sizes")))
(sha256
(base32 "1svzm3xahb2m8r79ha9gb1z3zlckykx9d87cghswj7dxn9868j4b"))))
(build-system gnu-build-system)
- (outputs '("out" ; TrueType version
- "pcf" ; PCF (bitmap) version
- "psf" ; PSF (console) version
+ (outputs '("out" ; Fonts
"bin")) ; Utilities to manipulate '.hex' format
(arguments
'(#:tests? #f ; no check target
@@ -705,10 +703,10 @@ for use at smaller text sizes")))
(lambda* (#:key outputs #:allow-other-keys)
(let* ((ttf (string-append (assoc-ref outputs "out")
"/share/fonts/truetype"))
- (pcf (string-append (assoc-ref outputs "pcf")
- "/share/fonts/misc"))
- (psf (string-append (assoc-ref outputs "psf")
- "/share/consolefonts"))
+ (pcf (string-append (assoc-ref outputs "out")
+ "/share/fonts/portablecompiled"))
+ (psf (string-append (assoc-ref outputs "out")
+ "/share/fonts/pcscreen"))
(bin (assoc-ref outputs "bin")))
(invoke "make"
(string-append "PREFIX=" bin)
--
2.26.2