diff mbox series

[bug#69581,06/11] gnu: syncthing: Mark as tunable.

Message ID a655ad3c7676d4a374a35e9464aa628bdd3cfea8.1709722620.git.efraim@flashner.co.il
State New
Headers show
Series CPU tuning patches | expand

Commit Message

Efraim Flashner March 6, 2024, 11:06 a.m. UTC
* gnu/packages/syncthing.scm (syncthing)[properties]: Mark package as
tunable.

Change-Id: Ia885bbd32f043e83b231359cca438ea9caf4e8dc
---
 gnu/packages/syncthing.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Ludovic Courtès March 6, 2024, 6:06 p.m. UTC | #1
Efraim Flashner <efraim@flashner.co.il> skribis:

> * gnu/packages/syncthing.scm (syncthing)[properties]: Mark package as
> tunable.

[...]

> +       (tunable? . #t)))

I’m skeptical; why would a backup program benefit from vector ISA
extensions?

Ludo’.
Efraim Flashner March 7, 2024, 9:09 a.m. UTC | #2
On Wed, Mar 06, 2024 at 07:06:04PM +0100, Ludovic Courtès wrote:
> Efraim Flashner <efraim@flashner.co.il> skribis:
> 
> > * gnu/packages/syncthing.scm (syncthing)[properties]: Mark package as
> > tunable.
> 
> [...]
> 
> > +       (tunable? . #t)))
> 
> I’m skeptical; why would a backup program benefit from vector ISA
> extensions?

There's a fair amount of hashing and other bits that happen in
syncthing, not just sending files over the network. IIRC when the GOAMD
support was added hashing was specifically shown to have a massive boost
from targeting newer micro-architectures.

Also this is the package I always end up enabling tuning on when
experimenting with tuning and go.
diff mbox series

Patch

diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index d09b03bcdb..6986642b73 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -129,7 +129,8 @@  (define-public syncthing
     (home-page "https://github.com/syncthing/syncthing")
     (properties
      '((release-monitoring-url . "https://syncthing.net/downloads/")
-       (upstream-name . "syncthing-source")))
+       (upstream-name . "syncthing-source")
+       (tunable? . #t)))
     (license mpl2.0)))
 
 (define-public syncthing-gtk