mbox series

[bug#69581,00/11] CPU tuning patches

Message ID cover.1709722620.git.efraim@flashner.co.il
Headers show
Series CPU tuning patches | expand

Message

Efraim Flashner March 6, 2024, 11:03 a.m. UTC
This series corrects the remaining x86_64-v* to x86-64-v*, which is what
the compiler expects. It also removes x86-64-v1, which is the baseline,
and instead inserts x86-64. Software for i686 running on x86_64 can
still benefit from the tuning from x86_64, so I've added those options
for gcc.

I've added support for tuning rust packages, and I've marked rav1e as
tunable since it apparently shows a large boost when tuned to newer
hardware.  I've also added opus and libvorbis since they benefit
greatly, and syncthing since, beyond syncing, there is a lot of other
hashing and whatnot that it does that benefits from tuning.

I've updated the llvm micro-architecture list for x86_64, and I've added
for powerpc64le. I was going to add for aarch64 but it only supports
listing specific chips so that didn't fit with what we have elsewhere.

Efraim Flashner (11):
  gnu: opus: Mark as tunable.
  gnu: libvorbis: Mark as tunable.
  guix: cpu: Be consistent with x86_64 micro-architecture names.
  guix: cpu: Rename x86-64-v1 to x86-64.
  guix: cpu: Enable tuning for i686-linux.
  gnu: syncthing: Mark as tunable.
  gnu: rust: Add tuning information.
  transformations: Add support for rust.
  gnu: rav1e: Mark as tunable.
  gnu: clang-properties: Update x86_64 micro-architectures.
  gnu: clang-properties: Add micro-architecture support for powerpc64le.

 gnu/packages/gcc.scm       |   7 +-
 gnu/packages/golang.scm    |   3 +-
 gnu/packages/llvm.scm      | 127 +++++++++++++++++++------------------
 gnu/packages/rust.scm      |   4 +-
 gnu/packages/syncthing.scm |   3 +-
 gnu/packages/video.scm     |   1 +
 gnu/packages/xiph.scm      |   2 +
 guix/cpu.scm               |  24 +++----
 guix/transformations.scm   |   8 ++-
 9 files changed, 101 insertions(+), 78 deletions(-)


base-commit: f3ea06baca2b96cd20170616fd5da13ec2daac54

Comments

Efraim Flashner March 10, 2024, 10:51 a.m. UTC | #1
Patches pushed!