diff mbox series

[bug#62389,01/12] gnu: Add python-matrix-common.

Message ID a4678e8fbfb152bcc66c3cc7abfc3c3561754d80.1679505128.git.contact@conses.eu
State New
Headers show
Series gnu: synapse: Update to 1.67.0 | expand

Commit Message

Miguel Ángel Moreno March 22, 2023, 5:30 p.m. UTC
* gnu/packages/python-xyz.scm (python-matrix-common): New variable.
---
 gnu/packages/python-xyz.scm | 41 +++++++++++++++++++++++++++++++++++++
 1 file changed, 41 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index abe4862121..e394341805 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7220,6 +7220,47 @@  (define-public python-matplotlib-venn
 three-way Venn diagrams in @code{matplotlib}.")
     (license license:expat)))
 
+(define-public python-matrix-common
+  (package
+    (name"python-matrix-common")
+    (version "1.2.1")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "matrix_common" version))
+              (sha256
+               (base32
+                "0lrqzb6s57fxp0kwffdqnkr2pj9aia459cv1b95b55dxlq1cz7d9"))))
+    (build-system python-build-system)
+    (arguments
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (replace 'build
+            (lambda _
+              (setenv "SOURCE_DATE_EPOCH"
+                      (number->string (* 10 366 24 60 60)))
+              (invoke "python" "-m" "build" "--wheel" "--no-isolation" ".")))
+          (replace 'install
+            (lambda _
+              (let ((whl (car (find-files "dist" "\\.whl$"))))
+                (invoke "pip" "--no-cache-dir" "--no-input"
+                        "install" "--no-deps" "--prefix" #$output whl))))
+          (replace 'check
+            (lambda* (#:key tests? #:allow-other-keys)
+              (when tests?
+                (invoke "pytest" "-vv" "tests")))))))
+    (native-inputs
+     (list
+      python-pypa-build
+      python-pytest
+      python-setuptools-scm
+      python-wheel))
+    (home-page "https://github.com/matrix-org/matrix-python-common")
+    (synopsis "Common code for Synapse, Sydent and Sygnal")
+    (description "This package provides common utilities for Synapse, Sydent
+and Sygnal.")
+    (license license:asl2.0)))
+
 (define-public python-pysnptools
   (package
     (name "python-pysnptools")