diff mbox series

[bug#62389,11/12] gnu: Add python-txredisapi.

Message ID 76b2696950df989cc65f1095d3d6b40b5a8db9bd.1679505128.git.contact@conses.eu
State New
Headers show
Series gnu: synapse: Update to 1.67.0 | expand

Commit Message

Miguel Ángel Moreno March 22, 2023, 5:32 p.m. UTC
* gnu/packages/python-xyz.scm (python-txredisapi): New variable.
---
 gnu/packages/python-xyz.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7f15c6340f..bb5e5fcf50 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -24845,6 +24845,25 @@  (define-public python-txaio
 @code{asyncio} module and @code{Twisted}.")
     (license license:expat)))
 
+(define-public python-txredisapi
+  (package
+    (name "python-txredisapi")
+    (version "1.4.9")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "txredisapi" version))
+              (sha256
+               (base32
+                "0na5x3b53ni98h1cyakac36mqzgyldvfn6a7z270nkays1i70q69"))))
+    (build-system python-build-system)
+    (propagated-inputs (list python-pyopenssl python-six python-twisted))
+    (home-page "http://github.com/IlyaSkriblovsky/txredisapi")
+    (synopsis "Non-blocking redis client for Python")
+    (description "Non-blocking client driver for the redis database, written
+in Python.  It uses Twisted for the asynchronous communication with
+redis.")
+    (license license:asl2.0)))
+
 (define-public python-toolshed
   (package
     (name "python-toolshed")