diff mbox series

[bug#57347,v2,2/2] packages: Update man-pages package to newer style.

Message ID a31c4644ab30fbbfeaa18bb3fa08585529261a77.1661639742.git.lilah@lunabee.space
State Accepted
Headers show
Series [bug#57347,v2,1/2] packages: Add man-pages-posix. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Lilah Tascheter Aug. 27, 2022, 11:37 p.m. UTC
* gnu/packages/man.scm (man-pages)[arguments]: Refer to package output
  using gexps instead of assoc-ref on a parameter.
---
 gnu/packages/man.scm | 6 ++----
 1 file changed, 2 insertions(+), 4 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/man.scm b/gnu/packages/man.scm
index a3c6bb6aa4..863006f3cc 100644
--- a/gnu/packages/man.scm
+++ b/gnu/packages/man.scm
@@ -282,7 +282,7 @@  (define-public man-pages
         (base32 "12vb15gs56g8wl5nqlm4llr508brh4m2lfknhq4lizbxzqzawkb1"))))
     (build-system gnu-build-system)
     (arguments
-     '(#:phases (modify-phases %standard-phases (delete 'configure))
+     `(#:phases (modify-phases %standard-phases (delete 'configure))
 
        ;; The 'all' target depends on three targets that directly populate
        ;; $(MANDIR) based on its current contents.  Doing that in parallel
@@ -290,9 +290,7 @@  (define-public man-pages
        #:parallel-build? #f
 
        #:tests? #f
-       #:make-flags (list (string-append "mandir="
-                                         (assoc-ref %outputs "out")
-                                         "/share/man"))))
+       #:make-flags ,#~(list (string-append "mandir=" #$output "/share/man"))))
     (home-page "https://www.kernel.org/doc/man-pages/")
     (synopsis "Development manual pages from the Linux project")
     (description