diff mbox series

[bug#57347,v2,1/2] packages: Add man-pages-posix.

Message ID 467b59d4f414a8c1c58942bbc61c057c04da1aca.1661639742.git.lilah@lunabee.space
State Accepted
Headers show
Series [bug#57347,v2,1/2] packages: Add man-pages-posix. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Lilah Tascheter Aug. 27, 2022, 11:37 p.m. UTC
* gnu/packages/man.scm (man-pages-posix): New variable.
---
 gnu/packages/man.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)


base-commit: ff3cecffafad0ddf5cc2af6cb676e73bcf58e431

Comments

M Aug. 29, 2022, 7:36 p.m. UTC | #1
These two patches look good to me (not verified locally, but if it 
builds for you it should build for everyone).

Greetings,
Maxime (not a committer, though I do some reviewing)
Ludovic Courtès Sept. 8, 2022, 12:55 p.m. UTC | #2
Hi Lilah,

Lilah Tascheter <lilah@lunabee.space> skribis:

> * gnu/packages/man.scm (man-pages-posix): New variable.

[...]

> * gnu/packages/man.scm (man-pages)[arguments]: Refer to package output
>   using gexps instead of assoc-ref on a parameter.

Applied (with minor tweaks to the man-pages-posix description), thanks!

And thank you Maxime for reviewing.

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/man.scm b/gnu/packages/man.scm
index 1c1d82758b..a3c6bb6aa4 100644
--- a/gnu/packages/man.scm
+++ b/gnu/packages/man.scm
@@ -302,6 +302,38 @@  (define-public man-pages
     ;; Each man page has its own license; some are GPLv2+, some are MIT/X11.
     (license license:gpl2+)))
 
+(define-public man-pages-posix
+  (package
+    (name "man-pages-posix")
+    (version "2013-a")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append "mirror://kernel.org/linux/docs/man-pages/"
+                            "man-pages-posix/man-pages-posix-" version
+                            ".tar.xz"))
+        (sha256
+         (base32 "0258j05zdrxpgdj8nndbyi7bvrs8fxdksb0xbfrylzgzfmf3lqqr"))))
+    (build-system gnu-build-system)
+    (arguments
+      `(#:tests? #f
+        ;; The compress-documentation phase doesn't pick up on our manpages as
+        ;; its regex doesn't support trailing letters, so manually compress.
+        #:make-flags ,#~(list (string-append "prefix=" #$output) "gz")
+        #:license-file-regexp "POSIX-COPYRIGHT"
+        #:phases (modify-phases %standard-phases (delete 'configure))))
+    (home-page "https://www.kernel.org/doc/man-pages/")
+    (synopsis "Man pages from the POSIX.1-2013 standard")
+    (description "Excerpts from the POSIX.1-2008 and TC1 standards
+(collectively, POSIX.1-2013) in manual page form. While the Linux man-pages
+project documents the system as it exists on Linux- and glibc-based systems,
+this package documents the portable software API as nominally implemented by
+many unix-likes.")
+    (license (license:fsdg-compatible "file://POSIX-COPYRIGHT"
+               "Redistribution of this material is permitted so long as this
+notice and the corresponding notices within each POSIX manual page are retained
+on any distribution, and the nroff source is included."))))
+
 (define-public help2man
   ;; TODO: Manual pages for languages not available from the implicit
   ;; input "locales" contain the original (English) text.