diff mbox series

[bug#63854,core-updates,v3,1/2] gnu: libxml2: Add SGML_CATALOG_FILES to native-search-path.

Message ID a1c2e8847ce91e0462ba908ba65a2cd97b7b2e79.1687217685.git.gemmaro.dev@gmail.com
State New
Headers show
Series gnu: po4a: Fix SGML tests. | expand

Commit Message

gemmaro June 19, 2023, 11:47 p.m. UTC
* gnu/packages/xml.scm (libxml2)[native-search-paths]: Add SGML_CATALOG_FILES.
---
 gnu/packages/xml.scm | 27 +++++++++++++++++++--------
 1 file changed, 19 insertions(+), 8 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 8d9974b825c..e376f0f09b2 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -33,6 +33,7 @@ 
 ;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
 ;;; Copyright © 2021 David Larsson <david.larsson@selfhosted.xyz>
 ;;; Copyright © 2021 Matthew James Kraai <kraai@ftbfs.org>
+;;; Copyright © 2023 gemmaro <gemmaro.dev@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -222,14 +223,24 @@  (define-public libxml2
     (inputs (list xz))
     (propagated-inputs (list zlib)) ; libxml2.la says '-lz'.
     (native-inputs (list perl))
-    ;; $XML_CATALOG_FILES lists 'catalog.xml' files found in under the 'xml'
-    ;; sub-directory of any given package.
-    (native-search-paths (list (search-path-specification
-                                (variable "XML_CATALOG_FILES")
-                                (separator " ")
-                                (files '("xml"))
-                                (file-pattern "^catalog\\.xml$")
-                                (file-type 'regular))))
+    (native-search-paths
+     (list
+      ;; $XML_CATALOG_FILES lists 'catalog.xml' files found in under the 'xml'
+      ;; sub-directory of any given package.
+      (search-path-specification
+       (variable "XML_CATALOG_FILES")
+       (separator " ")
+       (files '("xml"))
+       (file-pattern "^catalog\\.xml$")
+       (file-type 'regular))
+      ;; $SGML_CATALOG_FILES lists 'catalog' or 'CATALOG' or '*.cat' files found
+      ;; under the 'sgml' sub-directory of any given package.
+      (search-path-specification
+       (variable "SGML_CATALOG_FILES")
+       (separator ":")
+       (files '("sgml"))
+       (file-pattern "^catalog$|^CATALOG$|^.*\\.cat$")
+       (file-type 'regular))))
     (search-paths native-search-paths)
     (description
      "Libxml2 is the XML C parser and toolkit developed for the Gnome