diff mbox series

[bug#63854,core-updates,v3,2/2] gnu: po4a: Fix SGML tests.

Message ID 7080ff0ecfe6817501ab3eb64d200158d17c595a.1687217685.git.gemmaro.dev@gmail.com
State New
Headers show
Series gnu: po4a: Fix SGML tests. | expand

Commit Message

gemmaro June 19, 2023, 11:47 p.m. UTC
* gnu/packages/gettext.scm (po4a): Fix SGML tests.
---
 gnu/packages/gettext.scm | 12 +++++-------
 1 file changed, 5 insertions(+), 7 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/gettext.scm b/gnu/packages/gettext.scm
index 114d8cf7afd..92bc506dd04 100644
--- a/gnu/packages/gettext.scm
+++ b/gnu/packages/gettext.scm
@@ -11,7 +11,7 @@ 
 ;;; Copyright © 2019 Miguel <rosen644835@gmail.com>
 ;;; Copyright © 2020, 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
 ;;; Copyright © 2020 EuAndreh <eu@euandre.org>
-;;; Copyright © 2022 gemmaro <gemmaro.dev@gmail.com>
+;;; Copyright © 2022, 2023 gemmaro <gemmaro.dev@gmail.com>
 ;;; Copyright © 2023 Maxim Cournoyer maxim.cournoyer@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
@@ -278,23 +278,21 @@  (define-public po4a
                 (for-each (lambda (file)
                             (wrap-program file
                               `("PERL5LIB" ":" prefix (,path))))
-                          (find-files bin "\\.*$")))))
-          (add-before 'check 'disable-failing-tests
-            (lambda _
-              ;; FIXME: fails despite of importing SGMLS
-              (delete-file "t/fmt-sgml.t"))))))
+                          (find-files bin "\\.*$"))))))))
     (native-inputs
      (list gettext-minimal
            perl-module-build
            docbook-xsl
-           libxml2
+           libxml2 ;for SGML_CATALOG_FILES
            libxslt
            ;; For tests.
+           docbook-sgml-4.1
            docbook-xml-4.1.2
            perl-test-pod
            texlive-tiny))
     (inputs
      (list bash-minimal
+           opensp
            perl-gettext
            perl-pod-parser
            perl-sgmls