diff mbox series

[bug#59896,2/5] gnu: clingo: Update to 5.6.2.

Message ID a1b183dd1cdaf8aa085e438f0f1ef027f173068f.camel@gmail.com
State New
Headers show
Series Update clingo and add telingo | expand

Commit Message

Liliana Marie Prikler Dec. 8, 2022, 8:33 a.m. UTC
* gnu/packages/maths.scm (clingo): Update to 5.6.2.
[source]: Unbundle clasp and catch.
[arguments]<#:configure-flags>: Add “-DCLINGO_USE_LOCAL_CLASP=off” and
“-DCLINGO_USE_LOCAL_CATCH=off”.
[inputs]: Add catch2-3.1.
[native-inputs]: Add pkg-config.
---
 gnu/packages/maths.scm | 23 ++++++++++++-----------
 1 file changed, 12 insertions(+), 11 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index c0bc07977b..6a55284308 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -2625,27 +2625,30 @@  (define-public clasp
 (define-public clingo
   (package
     (name "clingo")
-    (version "5.5.0")
+    (version "5.6.2")
     (source (origin
               (method git-fetch)
               (uri (git-reference
                     (url "https://github.com/potassco/clingo")
                     (commit (string-append "v" version))))
               (file-name (git-file-name name version))
+              (modules '((guix build utils)))
+              (snippet
+               #~(begin
+                   (delete-file-recursively "clasp")
+                   ;; TODO: Unvendor other third-party stuff
+                   (delete-file-recursively "third_party/catch")))
               (sha256
                (base32
-                "0rfjwkcwm0mmf3r4i7asyjwb6cia4i7px7fn2kdbi9j85qvas4pb"))))
+                "19s59ndcm2yj0kxlikfxnx2bmp6b7n31wq1zvwc7hyk37rqarwys"))))
     (build-system cmake-build-system)
     (arguments
      `(#:configure-flags `("-DCLINGO_BUILD_TESTS=on"
                            "-DCLINGO_INSTALL_LIB=on"
                            "-DCLINGO_BUILD_STATIC=off"
                            "-DCLINGO_BUILD_SHARED=on"
-                           ;; XXX: Clingo requries private headers and
-                           ;;      sources from clasp
-                           ,(string-append
-                             "-DCLASP_SOURCE_DIR="
-                             (assoc-ref %build-inputs "clasp-src")))
+                           "-DCLINGO_USE_LOCAL_CLASP=off"
+                           "-DCLINGO_USE_LOCAL_CATCH=off")
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'patch-cmake
@@ -2677,10 +2680,8 @@  (define-public clingo
                                "unpool-ast-v2" "parse_term"
                                "propagator" "propgator-sequence-mining"
                                "symbol" "visitor"))))))))))
-    (inputs
-     (list clasp libpotassco))
-    (native-inputs
-     `(("clasp-src" ,(package-source clasp))))
+    (inputs (list catch2-3.1 clasp libpotassco))
+    (native-inputs (list pkg-config))
     (home-page "https://potassco.org/")
     (synopsis "Grounder and solver for logic programs")
     (description "Clingo computes answer sets for a given logic program.")