diff mbox series

[bug#59896,5/5] gnu: Add python-telingo.

Message ID 1da46d86f9d5850afe7f8f14070a3c025dbae3f7.camel@gmail.com
State New
Headers show
Series Update clingo and add telingo | expand

Commit Message

Liliana Marie Prikler Dec. 8, 2022, 8:49 a.m. UTC
* gnu/packages/patches/python-telingo-fix-comparison.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register it.
* gnu/packages/maths.scm (python-telingo): New variable.
---
 gnu/local.mk                                  |  1 +
 gnu/packages/maths.scm                        | 23 +++++++++++++++++++
 .../python-telingo-fix-comparison.patch       | 19 +++++++++++++++
 3 files changed, 43 insertions(+)
 create mode 100644 gnu/packages/patches/python-telingo-fix-comparison.patch

Comments

Liliana Marie Prikler Dec. 15, 2022, 4 p.m. UTC | #1
Am Donnerstag, dem 08.12.2022 um 09:49 +0100 schrieb Liliana Marie
Prikler:
> * gnu/packages/patches/python-telingo-fix-comparison.patch: New file.
> * gnu/local.mk (dist_patch_DATA): Register it.
> * gnu/packages/maths.scm (python-telingo): New variable.
Pushed along with the rest.
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index 3329801fa6..0ada842407 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1644,6 +1644,7 @@  dist_patch_DATA =						\
   %D%/packages/patches/python-louvain-fix-test.patch		\
   %D%/packages/patches/python-random2-getrandbits-test.patch		\
   %D%/packages/patches/python-poppler-qt5-fix-build.patch	\
+  %D%/packages/patches/python-telingo-fix-comparison.patch	\
   %D%/packages/patches/python-w3lib-fix-test-failure.patch	\
   %D%/packages/patches/sdcc-disable-non-free-code.patch		\
   %D%/packages/patches/sdl-pango-api_additions.patch		\
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 4f057820f0..23c886dfdb 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -92,6 +92,7 @@  (define-module (gnu packages maths)
   #:use-module (guix build-system ocaml)
   #:use-module (guix build-system perl)
   #:use-module (guix build-system python)
+  #:use-module (guix build-system pyproject)
   #:use-module (guix build-system ruby)
   #:use-module (gnu packages algebra)
   #:use-module (gnu packages audio)
@@ -2717,6 +2718,28 @@  (define-public python-clingo
 making it so that you can write @acronym{ASPs, Answer Set Programs} through
 Python code.")))
 
+(define-public python-telingo
+  (package
+    (name "python-telingo")
+    (version "2.1.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/potassco/telingo")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (patches (search-patches "python-telingo-fix-comparison.patch"))
+              (sha256
+               (base32
+                "0g3khxfdzc2hc7dkiyyqhb399h6h21m5wkp6wy8w71n0m32fiy53"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs (list python-clingo))
+    (home-page "https://potassco.org/")
+    (synopsis "Solve dynamic temporal logic programs")
+    (description "This package provides a system to solve dynamic temporal
+logic programs based on clingo.")
+    (license license:expat)))
+
 (define-public ceres
   (package
     (name "ceres-solver")
diff --git a/gnu/packages/patches/python-telingo-fix-comparison.patch b/gnu/packages/patches/python-telingo-fix-comparison.patch
new file mode 100644
index 0000000000..6d05048dcb
--- /dev/null
+++ b/gnu/packages/patches/python-telingo-fix-comparison.patch
@@ -0,0 +1,19 @@ 
+Index: source/telingo/transformers/head.py
+===================================================================
+--- source.orig/telingo/transformers/head.py
++++ source/telingo/transformers/head.py
+@@ -564,10 +564,12 @@ class HeadTransformer:
+                 cond = []
+                 diff = _ast.BinaryOperation(loc, _ast.BinaryOperator.Minus, param, shift)
+                 if lhs.ast_type != _ast.ASTType.SymbolicTerm or lhs.symbol.type != _clingo.SymbolType.Number or lhs.symbol.number > 0:
+-                    cond.append(_ast.Literal(loc, _ast.Sign.NoSign, _ast.Comparison(_ast.ComparisonOperator.LessEqual, lhs, diff)))
++                    cond.append(_ast.Literal(loc, _ast.Sign.NoSign,
++                                             _ast.Comparison(lhs, [_ast.Guard(_ast.ComparisonOperator.LessEqual, diff)])))
+ 
+                 if rhs.ast_type != _ast.ASTType.SymbolicTerm or rhs.symbol.type != _clingo.SymbolType.Supremum:
+-                    cond.append(_ast.Literal(loc, _ast.Sign.NoSign, _ast.Comparison(_ast.ComparisonOperator.LessEqual, diff, rhs)))
++                    cond.append(_ast.Literal(loc, _ast.Sign.NoSign,
++                                             _ast.Comparison(diff, [_ast.Guard(_ast.ComparisonOperator.LessEqual, rhs)])))
+ 
+                 elems.extend([_ast.ConditionalLiteral(loc, _ast.Literal(loc, _ast.Sign.NoSign, head), cond) for head in heads])
+