diff mbox series

[bug#68207,1/5] gnu: python-markdown-it-py: Update to 3.0.0.

Message ID a1b0aedd41d4a4be7a7d21f73b5f42dd5aaee4da.1704207105.git.felgru@posteo.net
State New
Headers show
Series Update python-textual to 0.46.0. | expand

Commit Message

Felix Gruber Jan. 2, 2024, 3:05 p.m. UTC
* gnu/packages/python-xyz.scm (python-markdown-it-py): Update to 3.0.0.
[propagated-inputs]: Remove python-typing-extensions; add python-commonmark,
python-linkify-it-py, python-markdown, python-mistletoe,
python-mistune, python-panflute, python-psutil, and python-pyyaml.
[native-inputs]: Remove python-flit; add python-flit-core.

Change-Id: I5dc06b163ddbec0a32a9d7c3da2c834b2e74cd74
---
 gnu/packages/python-xyz.scm | 17 ++++++++++++-----
 1 file changed, 12 insertions(+), 5 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2afce6c667..3894f77f2e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5482,19 +5482,26 @@  (define-public python-makefun
 (define-public python-markdown-it-py
   (package
     (name "python-markdown-it-py")
-    (version "2.1.0")
+    (version "3.0.0")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "markdown-it-py" version))
               (sha256
                (base32
-                "1nh75i72584r70alhqc479gys04s5m5g3vq601yf2njbs7z5jzng"))))
+                "1swgvyiavak0nmfb31lq5zck5chwhmyf6qb6qwpcav86zaa0mxp3"))))
     (build-system pyproject-build-system)
     (arguments (list #:tests? #f))      ;pypi source does not contains tests
-    (native-inputs (list python-flit))
+    (native-inputs (list python-flit-core))
     (propagated-inputs
-     (list python-mdurl
-           python-typing-extensions))
+     (list python-commonmark
+           python-linkify-it-py
+           python-markdown
+           python-mdurl
+           python-mistletoe
+           python-mistune
+           python-panflute
+           python-psutil
+           python-pyyaml))
     (home-page "https://github.com/executablebooks/markdown-it-py")
     (synopsis "Python port of markdown-it")
     (description