diff mbox series

[bug#68207,3/5] gnu: Add python-pygments-next.

Message ID 36515d2ec085b5ebde02e665eef0cc005168aca9.1704207105.git.felgru@posteo.net
State New
Headers show
Series Update python-textual to 0.46.0. | expand

Commit Message

Felix Gruber Jan. 2, 2024, 3:05 p.m. UTC
* gnu/packages/python-xyz.scm (python-pygments-next): New variable.

Change-Id: I12e3e0d6042f34e0375bcbb1dc90ccc9ed9ce050
---
 gnu/packages/python-xyz.scm | 15 +++++++++++++++
 1 file changed, 15 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d4f4766c5b..d0a8f900b3 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6189,6 +6189,21 @@  (define-public python-pygments
      "Pygments is a syntax highlighting package written in Python.")
     (license license:bsd-2)))
 
+(define-public python-pygments-next
+  (package
+    (inherit python-pygments)
+    (name "python-pygments-next")
+    (version "2.17.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pygments" version))
+       (sha256
+        (base32
+         "0ry3qi4rszkiqb20bmjlzys71dja9i746kvqi8xbxr9dzp4wwins"))))
+    (build-system pyproject-build-system)
+    (native-inputs (list python-hatchling))))
+
 (define-public python-pygments-github-lexers
   (package
     (name "python-pygments-github-lexers")