diff mbox series

[bug#66886,3/5] gnu: python-rich: Update to 13.6.0.

Message ID a1391e837506184272ee9c60cea9e4b485cf152a.1698858108.git.goodoldpaul@autistici.org
State New
Headers show
Series [bug#66886,1/5] gnu: Add python-pygments-2.16. | expand

Commit Message

Giacomo Leidi Nov. 1, 2023, 5:01 p.m. UTC
* gnu/packages/python-xyz.scm (python-rich): Update to 13.6.0;
[source]: switch to git-origin to have tests;
[build-system]: switch to pyproject-build-system;
[arguments]: remove it since this boilerplate is now handled by the
pyproject-build-system;
[propagated-inputs]: remove python-colorama as it's not listed on
pyproject.toml;
replace python-commonmark with python-markdown-it-py;
use python-pygments-2.16;
move python-attrs from here...;
[native-inputs]: ...to here;
drop "tests" input;
add python-pytest-cov;
[home-page]: https://github.com/willmcgugan/rich now redirects to
https://github.com/Textualize/rich .

Change-Id: I16ea6f27d24f84d86db659c224705c81fac3b42e
---
 gnu/packages/python-xyz.scm | 43 ++++++++++---------------------------
 1 file changed, 11 insertions(+), 32 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 810d86f04e..9e79cf8140 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18168,43 +18168,22 @@  (define-public python-slugid
 (define-public python-rich
   (package
     (name "python-rich")
-    (version "12.4.1")
+    (version "13.6.0")
     (source (origin
-              (method url-fetch)
-              (uri (pypi-uri "rich" version))
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/Textualize/rich")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
               (sha256
                (base32
-                "149vjb4cpf9mz14iig0b6d8065dm8aslp6pc45g9ipmp1wf00ffj"))))
-    (build-system python-build-system)
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda* (#:key inputs tests? #:allow-other-keys)
-             (when tests?
-               (copy-recursively (string-append
-                                  (assoc-ref inputs "tests") "/tests")
-                                 "tests")
-               (invoke "python" "-m" "pytest" "-vv")))))))
+                "02cbi53il9j0zfwxi2lsaypj3wyfb70q2g2c1q0a3xk164dnnkfw"))))
+    (build-system pyproject-build-system)
     (propagated-inputs
-     (list python-attrs python-colorama python-commonmark python-pygments
-           python-typing-extensions))
+     (list python-markdown-it-py python-pygments-2.16 python-typing-extensions))
     (native-inputs
-     `(("python-pytest" ,python-pytest)
-       ("tests"
-        ;; The release on pypi comes without tests.  We can't build from this
-        ;; checkout, though, because installation requires an invocation of
-        ;; poetry.
-        ,(origin
-           (method git-fetch)
-           (uri (git-reference
-                 (url "https://github.com/willmcgugan/rich")
-                 (commit (string-append "v" version))))
-           (file-name (git-file-name name version))
-           (sha256
-            (base32
-             "17c3gljn8zv32xnpsgd3fqgqn4r7cdfqri41hridcpbhssdgkyp9"))))))
-    (home-page "https://github.com/willmcgugan/rich")
+     (list poetry python-attr python-pytest python-pytest-cov))
+    (home-page "https://github.com/Textualize/rich")
     (synopsis "Render rich text and more to the terminal")
     (description
      "This is a Python package for rendering rich text, tables, progress bars,