diff mbox series

[bug#63542,12/19] gnu: python-astroquery: Use Gexp.

Message ID a0f6e692504ec5f3edd8dee52b39d963395084ab.1684276665.git.sharlatanus@gmail.com
State New
Headers show
Series : gnu: astronomy: May updates. | expand

Commit Message

Sharlatan Hellseher May 16, 2023, 11:23 p.m. UTC
* gnu/packages/astronomy.scm (python-astroquery): Use Gexp to simplify
package style.
---
 gnu/packages/astronomy.scm | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

Comments

Vinicius Monego May 23, 2023, 10:15 p.m. UTC | #1
Em qua, 2023-05-17 às 00:23 +0100, Sharlatan Hellseher escreveu:
> * gnu/packages/astronomy.scm (python-astroquery): Use Gexp to
> simplify
> package style.
> ---
>  gnu/packages/astronomy.scm | 8 ++++----
>  1 file changed, 4 insertions(+), 4 deletions(-)
> 
> diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
> index be4961b49e..5f5de193d0 100644
> --- a/gnu/packages/astronomy.scm
> +++ b/gnu/packages/astronomy.scm
> @@ -1280,15 +1280,15 @@ (define-public python-astroquery
>          (base32
> "1vhkzsqlgn3ji5by2rdf2gwklhbyzvpzb1iglalhqjkkrdaaaz1h"))))
>      (build-system python-build-system)
> 

Astroquery contains pyproject.toml in its source code, did you attempt
to switch to pyproject-build-system here?

>      (arguments
> -     `(#:phases
> -       (modify-phases %standard-phases
> +     (list
> +      #:phases
> +       #~(modify-phases %standard-phases
>           (add-before 'check 'writable-home
>             (lambda _                    ; some tests need a writable
> home
>               (setenv "HOME" (getcwd))))
>           (replace 'check
> -           (lambda* (#:key inputs outputs tests? #:allow-other-keys)
> +           (lambda* (#:key tests? #:allow-other-keys)
>               (when tests?
> -               (add-installed-pythonpath inputs outputs)
>                 (invoke "python" "-m" "pytest" "--pyargs"
> "astroquery"
>                         ;; Skip tests that require online data.
>                         "-m" "not remote_data")))))))

[...]

Vinicius
diff mbox series

Patch

diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index be4961b49e..5f5de193d0 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1280,15 +1280,15 @@  (define-public python-astroquery
         (base32 "1vhkzsqlgn3ji5by2rdf2gwklhbyzvpzb1iglalhqjkkrdaaaz1h"))))
     (build-system python-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
+     (list
+      #:phases
+       #~(modify-phases %standard-phases
          (add-before 'check 'writable-home
            (lambda _                    ; some tests need a writable home
              (setenv "HOME" (getcwd))))
          (replace 'check
-           (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+           (lambda* (#:key tests? #:allow-other-keys)
              (when tests?
-               (add-installed-pythonpath inputs outputs)
                (invoke "python" "-m" "pytest" "--pyargs" "astroquery"
                        ;; Skip tests that require online data.
                        "-m" "not remote_data")))))))