diff mbox series

[bug#57608] Upstreaming KDE Plasma and rest of packages

Message ID X3go74odFaq331z5JbwC40xo6HkXw_5_aR6wB1_FX1nrpVHL8oFOE8QKK7I0yAH4ra1rAV06OWQCqcNvh9ZuFVQPUxZ9Jhro7QQ51AmRgG0=@protonmail.com
State New
Headers show
Series [bug#57608] Upstreaming KDE Plasma and rest of packages | expand

Commit Message

phodina Dec. 27, 2022, 9:15 p.m. UTC
Hi Marius,





Sent with Proton Mail secure email.

------- Original Message -------
On Tuesday, November 22nd, 2022 at 11:56 AM, Marius Bakke <marius@gnu.org> wrote:


> > Is this issue somewhere described? I've lately used more tarballs to git download on other packages.
> > Is the issue connected with any Gitlab/Forge or just the KDE and the release scripts?
> 
> 
> We have this problem with all the forges. There have been many-a bug
> report about it, and the linter also warns about it (apparently for
> GitHub only, that could be improved).

Thanks for the explanation. I'll keep that in mind.
> 
> > > * dropped the !! commits
> > > * Minor tweaks to synopses and descriptions
> > 
> > My apologies as I noticed there were few packages with wrong license or missing description.
> 
> 
> Oh, I did not license audit these packages as I assumed all the KDE
> stuffs were using the same license. Can you submit patches to update
> the licenses?

I've tried to follow the licenses as submitted by the individual packages. I'm currently in process
of double checking.


I found out that the kinfocenter and systemsettings were not behaving correctly - no widgets were
rendered due to missing QML modules. The attached patch solves this.

I have some additional patches for kwin and plasma-workspace but they are not yet enough to launch
KDE desktop.

Also one "small" problem. As I switched to sway to test apps running under Wayland I noticed a pretty
important issue. None of the programs launched were running under Wayland - they ran in XWayland.

Is this known issue?

Do we need to modify the qt-build-system or cmake-build-system? Or shall we add wrap phase for each
package to add the correct path for qtwayland package in env variable QT_QPA_PLATFORM_PLUGIN_PATH?

```
$ echo $XDG_SESSION_TYPE
wayland
$ konsole
qt.qpa.plugin: Could not find the Qt platform plugin "wayland" in ""
```

----
Petr

Comments

Maxim Cournoyer Dec. 28, 2022, 12:48 a.m. UTC | #1
Hi Petr,

phodina <phodina@protonmail.com> writes:

[...]

> Also one "small" problem. As I switched to sway to test apps running under Wayland I noticed a pretty
> important issue. None of the programs launched were running under Wayland - they ran in XWayland.
>
> Is this known issue?

It's known as #57742.  If you add qtwayland to the inputs of the
packages making use of it, it'll get captured in the wrapper and it'll
work.
diff mbox series

Patch

From 063ea2790d55780943a0bd07be64421106b22d4d Mon Sep 17 00:00:00 2001
From: Petr Hodina <phodina@protonmail.com>
Date: Mon, 26 Dec 2022 10:50:19 +0100
Subject: [PATCH] gnu: system-settings: Add phase 'wrap-executable and
 additional inputs.

* gnu/packages/kde-plasma.scm (system-settings)[inputs]: Add qtquickcontrols-5.
[arguments]: Add phase 'wrap-executable.
[inputs]: Add kcoreaddons, kdeclarative, knewstuff, kuserfeedback,
qtgraphicaleffects and qtquickcontrols2-5.

diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index 89405bacaa..157ac3e1dd 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -2495,9 +2495,34 @@  (define-public system-settings
                (base32
                 "0n7mf6ygi8fgn1m6pk2fadnqj1h58mxqni3h19xbi373wfypq5fl"))))
     (build-system qt-build-system)
+    (arguments
+     (list #:phases #~(modify-phases %standard-phases
+                        (add-after 'install 'wrap-executable
+                          (lambda* (#:key inputs #:allow-other-keys)
+                            (let ((out #$output)
+                                  (qml "/lib/qt5/qml"))
+                              (wrap-program (string-append out
+                                                           "/bin/systemsettings5")
+                                            `("QML2_IMPORT_PATH" ":" prefix
+                                              (,(string-append out qml)
+                                               ,@(map (lambda (i)
+                                                     (string-append
+                                                      (assoc-ref inputs i) qml))
+                                               '("kirigami"
+                                                 "kcoreaddons"
+                                                 "kdeclarative"
+                                                 "knewstuff"
+                                                 "kuserfeedback"
+                                                 "plasma-workspace"
+                                                 "qtdeclarative"
+                                                 "qtgraphicaleffects"
+                                                 "qtquickcontrols"
+                                                 "qtquickcontrols2")))))))))))
     (native-inputs (list extra-cmake-modules))
     (inputs (list kauth
                   kcrash
+                  kcoreaddons
+                  kdeclarative
                   kitemviews
                   kitemmodels
                   kcmutils
@@ -2511,14 +2536,19 @@  (define-public system-settings
                   kdbusaddons
                   kconfig
                   kpackage
+                  knewstuff
                   kactivities
                   kactivities-stats
                   kguiaddons
                   kirigami
                   knotifications
                   krunner
+                  kuserfeedback
                   plasma-workspace
-                  qtdeclarative-5))
+                  qtdeclarative-5
+                  qtgraphicaleffects
+                  qtquickcontrols-5
+                  qtquickcontrols2-5))
     (synopsis "Control center to configure Plasma Desktop")
     (description "This package provides configuration UI for Plasma Desktop.")
     (home-page "https://invent.kde.org/plasma/systemsettings")
-- 
2.38.1