@@ -33,6 +33,7 @@
#:use-module (guix git-download)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix build-system cmake)
+ #:use-module (guix build-system copy)
#:use-module (guix build-system gnu)
#:use-module (guix build-system python)
#:use-module (guix build-system trivial)
@@ -501,6 +502,34 @@ languages are C and C++.")
"--disable-nls")
,@(package-arguments gdb)))))
+(define-public gcc-msp430-support-files
+ (package
+ (name "gcc-msp430-support-files")
+ (version "1.212")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://software-dl.ti.com/msp430/msp430_public_sw/"
+ "mcu/msp430/MSPGCC/9_3_1_2/export/"
+ "msp430-gcc-support-files-" version ".zip"))
+
+ (sha256
+ (base32
+ "1mmqn1gql4sv369nks1v05jw1x6fpqssqq3yfvxzwk9l1bqkj6iv"))))
+ (build-system copy-build-system)
+ (home-page "https://www.ti.com/tool/MSP430-GCC-OPENSOURCE")
+ (synopsis "GCC headers and linker scripts for MSP430 microcontrollers")
+ (description "GCC headers and linker scripts for MSP430 microcontrollers")
+ (native-search-paths
+ (list (search-path-specification
+ (variable "CROSS_C_INCLUDE_PATH")
+ (files '("include")))
+ (search-path-specification
+ (variable "CROSS_LIBRARY_PATH")
+ (files '("include")))))
+ (native-inputs
+ `(("unzip" ,unzip)))
+ (license license:bsd-3)))
+
(define-public libjaylink
(package
(name "libjaylink")
From: Morgan Smith <Morgan.J.Smith@outlook.com> * gnu/packages/embedded.scm (gcc-msp430-support-files): New variable. --- gnu/packages/embedded.scm | 29 +++++++++++++++++++++++++++++ 1 file changed, 29 insertions(+)