diff mbox series

[bug#48767,5/6] gnu: Add gdb-msp430.

Message ID SN6PR05MB40314E4928AD3F7AEA7973BFC5A69@SN6PR05MB4031.namprd05.prod.outlook.com
State New
Headers show
Series [bug#48767,1/6] gnu: Add gcc-msp430-support-files. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Morgan Smith Sept. 26, 2021, 2:51 p.m. UTC
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/embedded.scm (gdb-msp430): New variable.
---
 gnu/packages/embedded.scm | 11 +++++++++++
 1 file changed, 11 insertions(+)

Comments

M Sept. 26, 2021, 4:16 p.m. UTC | #1
Morgan.J.Smith@outlook.com schreef op zo 26-09-2021 om 10:51 [-0400]:
> From: Morgan Smith <Morgan.J.Smith@outlook.com>
> 
> * gnu/packages/embedded.scm (gdb-msp430): New variable.
> ---
>  gnu/packages/embedded.scm | 11 +++++++++++
>  1 file changed, 11 insertions(+)
> 
> diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
> index 8401f68542..f79092de72 100644
> --- a/gnu/packages/embedded.scm
> +++ b/gnu/packages/embedded.scm
> @@ -636,6 +636,17 @@ The supported programming language is C.")
>  (define-public msp430-toolchain
>    (make-msp430-toolchain gcc-msp430 newlib-msp430))
>  
> +(define-public gdb-msp430
> +  (package
> +    (inherit gdb)
> +    (name "gdb-msp430")
> +    (arguments
> +     `(#:configure-flags '("--target=msp430-elf"
> +                           "--enable-languages=c,c++"
> +                           "--disable-nls"
> +                           "--enable-initfini-array")
> +       ,@(package-arguments gdb)))))

It would be more future-proof to use 'substitute-keyword-arguments' here,
as possibly a future package definition of 'gdb' could set #:configure-flags.

It would also be nice to adjust the description and synopsis a bit.
Maybe something like

 (synopsis "The GNU debugger for remotely debugging msp430 systems")
 (description "This is the GNU debugger, configured for debugging msp430 systems
from a system of another architecture.")

and add to the description of 'gdb' something like

 "This variant of the GNU debugger only supports debugging programs compiled for
the same architecture as the GNU debugger runs on.  For remote debugging, the
variants @code{gdb-msp430} or @code{gdb-arm-none-eabi} may be required."

(Assuming that's correct.)  (These descriptions could be improved.)

Greetings,
Maxime.
diff mbox series

Patch

diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index 8401f68542..f79092de72 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -636,6 +636,17 @@  The supported programming language is C.")
 (define-public msp430-toolchain
   (make-msp430-toolchain gcc-msp430 newlib-msp430))
 
+(define-public gdb-msp430
+  (package
+    (inherit gdb)
+    (name "gdb-msp430")
+    (arguments
+     `(#:configure-flags '("--target=msp430-elf"
+                           "--enable-languages=c,c++"
+                           "--disable-nls"
+                           "--enable-initfini-array")
+       ,@(package-arguments gdb)))))
+
 (define-public libjaylink
   (package
     (name "libjaylink")