diff mbox series

[bug#40101,1/3] gnu: Add r-argon2

Message ID Rh_a5PVREyUuoGEyjGAQj2WWiy_eR75m6piwx90wEfiwehyN0AaF_SNp2MYHH147Gd-eXsh71ZOaDIagMktare5Y1BTuDVwxIfAXL6NkXf4=@protonmail.com
State Accepted
Headers show
Series gnu: Add r-remoter and its dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/applying patch fail View Laminar job

Commit Message

ashish.is--- via Guix-patches" via March 17, 2020, 1:06 p.m. UTC
* gnu/packages/statistics.scm (r-argon2): New variable.
---
 gnu/packages/statistics.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

--
2.25.0
diff mbox series

Patch

diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 6616780081..7e3b62c035 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -5824,3 +5824,23 @@  Java package that provides routines for various statistical distributions.")
 Emacs.  It is designed to support editing of scripts and interaction with
 various statistical analysis programs such as R, Julia, and JAGS.")
     (license license:gpl2+)))
+
+(define-public r-argon2
+  (package
+    (name "r-argon2")
+    (version "0.2-0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "argon2" version))
+       (sha256
+        (base32
+         "0kqn06rpb39jlzizjlnc5c44mfic8llrshxn7ljgmyj35lbqwxqh"))))
+    (properties `((upstream-name . "argon2")))
+    (build-system r-build-system)
+    (home-page
+     "https://github.com/wrathematics/argon2")
+    (synopsis "Secure Password Hashing based on Argon2 Algorithm")
+    (description
+     "Utilities for secure password hashing via the argon2 algorithm.")
+    (license license:bsd-2)))