diff mbox series

[bug#40101,3/3] gnu: Add r-remoter

Message ID D2p5VbXq9MjhOxght1J__uQh141RU1w4Lw6tROuCiY7AAOf41MTl4Shnn-L0agTDvITUAxk4-2K370Cl5rwU16dq0DBipwPivf4tBgeL6pI=@protonmail.com
State Accepted
Headers show
Series gnu: Add r-remoter and its dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

ashish.is--- via Guix-patches" via March 17, 2020, 1:09 p.m. UTC
* gnu/packages/statistics.scm (r-remoter): New variable.
---
 gnu/packages/statistics.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

--
2.25.0






‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐
On Tuesday, 17 March 2020 13:56, <help-debbugs@gnu.org> wrote:

> Thank you for filing a new bug report with debbugs.gnu.org.
>
> This is an automatically generated reply to let you know your message
> has been received.
>
> Your message is being forwarded to the package maintainers and other
> interested parties for their attention; they will reply in due course.
>
> Your message has been sent to the package maintainer(s):
> guix-patches@gnu.org
>
> If you wish to submit further information on this problem, please
> send it to 40101@debbugs.gnu.org.
>
> Please do not send mail to help-debbugs@gnu.org unless you wish
> to report a problem with the Bug-tracking system.
>
> --------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
>
> 40101: http://debbugs.gnu.org/cgi/bugreport.cgi?bug=40101
> GNU Bug Tracking System
> Contact help-debbugs@gnu.org with problems
diff mbox series

Patch

diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index f161e6092e..216703e899 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -5869,3 +5869,30 @@  reading user input with masking, so that the input is not displayed as it is
 typed.  Currently, RStudio, the command line (every OS), and any platform
 where tcltk is present are supported.")
     (license license:bsd-2)))
+
+(define-public r-remoter
+  (package
+    (name "r-remoter")
+    (version "0.4-0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (cran-uri "remoter" version))
+        (sha256
+          (base32
+            "1a7m63l8phv5jnazvdqdrqkaqjwqzaac5y4jm2jn0ypy4n8jvkfl"))))
+    (properties `((upstream-name . "remoter")))
+    (build-system r-build-system)
+    (propagated-inputs
+      `(("r-argon2" ,r-argon2)
+        ("r-getpass" ,r-getpass)
+        ("r-pbdzmq" ,r-pbdzmq)
+        ("r-png" ,r-png)))
+    (home-page "https://github.com/RBigData/remoter")
+    (synopsis
+      "Control a Remote R Session from a Local One")
+    (description
+      "This package provides a set of utilities for client/server computing
+with R, controlling a remote R session (the server) from a local one (the
+client).")
+    (license license:bsd-2)))