diff mbox series

[bug#56150,2/2] gnu: mesa: Update configure flags.

Message ID OjI5zciS0ZOA6Ov7z9C-qoa-tZULYdr3sSuI4upIAUv-bsqs0VKjSjK-gpPT5sh6MXv7FhORL9uLtwMTkvXM65eFRiciajLYIhhMfWYlMBw=@protonmail.com
State Accepted
Headers show
Series gnu: mesa: Update to 22.1.2. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

John Kehayias June 22, 2022, 3:34 p.m. UTC
Empty Message
diff mbox series

Patch

From e18f9c4c1a1875b3ce7a1c5e5585eb4512e7e468 Mon Sep 17 00:00:00 2001
From: John Kehayias <john.kehayias@protonmail.com>
Date: Wed, 22 Jun 2022 11:19:39 -0400
Subject: [PATCH 2/2] gnu: mesa: Update configure flags.

* gnu/packages/gl.scm (mesa)[configure-flags]: Adjust the gallium-drivers and
vulkan-drivers flags to use "auto" where it is available and enables at least
the previously listed drivers.
---
 gnu/packages/gl.scm | 10 +++-------
 1 file changed, 3 insertions(+), 7 deletions(-)

diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 6c4594a9a1..a46e06827d 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -15,7 +15,7 @@ 
 ;;; Copyright © 2020, 2021, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2020 Kei Kebreau <kkebreau@posteo.net>
 ;;; Copyright © 2021 Ivan Gankevich <i.gankevich@spbu.ru>
-;;; Copyright © 2021 John Kehayias <john.kehayias@protonmail.com>
+;;; Copyright © 2021, 2022 John Kehayias <john.kehayias@protonmail.com>
 ;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
@@ -320,10 +320,10 @@  (define-public mesa
              ("armhf-linux"
               ;; Freedreno FTBFS when built on a 64-bit machine.
               '("-Dgallium-drivers=etnaviv,kmsro,lima,nouveau,panfrost,r300,r600,swrast,tegra,v3d,vc4,virgl"))
-             ((or "powerpc64le-linux" "powerpc-linux" "riscv64-linux")
+             ((or "powerpc64le-linux" "powerpc-linux")
               '("-Dgallium-drivers=nouveau,r300,r600,radeonsi,swrast,virgl"))
              (_
-              '("-Dgallium-drivers=iris,nouveau,r300,r600,radeonsi,svga,swrast,virgl")))
+              '("-Dgallium-drivers=auto")))
          ;; Enable various optional features.  TODO: opencl requires libclc,
          ;; omx requires libomxil-bellagio
          "-Dplatforms=x11,wayland"
@@ -340,14 +340,10 @@  (define-public mesa
 
          ;; Explicitly enable Vulkan on some architectures.
          ,@(match (%current-system)
-             ((or "i686-linux" "x86_64-linux")
-              '("-Dvulkan-drivers=intel,amd"))
              ((or "powerpc64le-linux" "powerpc-linux")
               '("-Dvulkan-drivers=amd,swrast"))
              ("aarch64-linux"
               '("-Dvulkan-drivers=freedreno,amd,broadcom,swrast"))
-             ("riscv64-linux"
-              '("-Dvulkan-drivers=amd,swrast"))
              (_
               '("-Dvulkan-drivers=auto")))
 
-- 
2.36.1