diff mbox series

[bug#56150,1/2] gnu: mesa: Update to 22.1.2.

Message ID 1OKhnGPP9yskCkMkUJ566lQQ0kPPm4zVMBtCdFxvPKMEeixjYGwu2Yt-0ZJdfmolGuIq-qPXn-pJe7xdgz9AuNrTdYeZEJfuLzcROMSWoAI=@protonmail.com
State Accepted
Headers show
Series gnu: mesa: Update to 22.1.2. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

John Kehayias June 22, 2022, 3:34 p.m. UTC
Empty Message
diff mbox series

Patch

From e89039567166f84f14aab61fa2c0982ac9f40543 Mon Sep 17 00:00:00 2001
From: John Kehayias <john.kehayias@protonmail.com>
Date: Wed, 22 Jun 2022 11:09:33 -0400
Subject: [PATCH 1/2] gnu: mesa: Update to 22.1.2.

* gnu/packages/gl.scm (mesa): Update to 22.1.2.
[configure-flags]: Remove dri-drivers as from v22.0 the Mesa classic OpenGL
drivers were removed.
[phases]: Re-enable test that previously failed on i686.
* gnu/packages/patches/mesa-skip-tests.patch: Update patch for current version.
---
 gnu/packages/gl.scm                        | 20 ++++----------------
 gnu/packages/patches/mesa-skip-tests.patch | 19 +++++++++----------
 2 files changed, 13 insertions(+), 26 deletions(-)

diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index c740c087dd..6c4594a9a1 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -261,7 +261,7 @@  (define libva-without-mesa
 (define-public mesa
   (package
     (name "mesa")
-    (version "21.3.8")
+    (version "22.1.2")
     (source
       (origin
         (method url-fetch)
@@ -273,7 +273,7 @@  (define-public mesa
                                   version "/mesa-" version ".tar.xz")))
         (sha256
          (base32
-          "19wx5plk6z0hhi0zdzxjx8ynl3lhlc5mbd8vhwqyk92kvhxjf3g7"))
+          "1smrvvh8l7xcccwfbccx9k0ihzh1whrnnwsmqb7i0gba99mj4w89"))
         (patches
          (search-patches "mesa-skip-tests.patch"))))
     (build-system meson-build-system)
@@ -357,15 +357,8 @@  (define-public mesa
          ;; Also enable the tests.
          "-Dbuild-tests=true"
 
-         ;; on non-intel systems, drop i915 and i965
-         ;; from the default dri drivers
-         ,@(match (%current-system)
-             ((or "x86_64-linux" "i686-linux")
-              '("-Ddri-drivers=i915,i965,nouveau,r200,r100"))
-             (_
-              '("-Ddri-drivers=nouveau,r200,r100")))
-
-                "-Dllvm=enabled")       ; default is x86/x86_64 only
+         ;; Enable LLVM; default is x86/x86_64 only.
+         "-Dllvm=enabled")
 
        ;; XXX: 'debugoptimized' causes LTO link failures on some drivers.  The
        ;; documentation recommends using 'release' for performance anyway.
@@ -413,11 +406,6 @@  (define-public mesa
                     ;; This test times out and receives SIGTERM.
                     (substitute* "src/amd/common/meson.build"
                       (("and not with_platform_windows") "and with_platform_windows"))))
-                 ("i686-linux"
-                  ;; Disable new test from Mesa 19 that fails on i686.  Upstream
-                  ;; report: <https://bugs.freedesktop.org/show_bug.cgi?id=110612>.
-                  `((substitute* "src/util/tests/format/meson.build"
-                      (("'u_format_test',") ""))))
                  ("aarch64-linux"
                   ;; The ir3_disasm test segfaults.
                   ;; The simplest way to skip it is to run a different test instead.
diff --git a/gnu/packages/patches/mesa-skip-tests.patch b/gnu/packages/patches/mesa-skip-tests.patch
index 7ff571dcf5..af61ea1658 100644
--- a/gnu/packages/patches/mesa-skip-tests.patch
+++ b/gnu/packages/patches/mesa-skip-tests.patch
@@ -5,15 +5,14 @@  completely with this patch:
 https://gitlab.freedesktop.org/mesa/mesa/-/issues/4091
 
 diff --git a/src/util/meson.build b/src/util/meson.build
-index 319b22d9bf7..93790c72675 100644
+index 2a1028f0d3a..0d31f38b671 100644
 --- a/src/util/meson.build
 +++ b/src/util/meson.build
-@@ -344,7 +344,7 @@ if with_tests
-     )
-   endif
- 
--  foreach t: ['bitset', 'register_allocate', 'u_debug_stack', 'u_qsort']
-+  foreach t: ['bitset', 'register_allocate', 'u_qsort']
-     test(
-       t,
-       executable(
+@@ -330,7 +330,6 @@ if with_tests
+     'tests/set_test.cpp',
+     'tests/sparse_array_test.cpp',
+     'tests/u_atomic_test.cpp',
+-    'tests/u_debug_stack_test.cpp',
+     'tests/u_printf_test.cpp',
+     'tests/u_qsort_test.cpp',
+     'tests/vector_test.cpp',
-- 
2.36.1