diff mbox series

[bug#49620,2/2] Add pirate-get

Message ID Ko2gpHllZIoGR5jyOu1v0rgJSa-DpfJZ6aJK1EYq0ooMcI3D_kkBPw-k86vgqdMe2py1XWJ1Mo00o-mv-9ayQwsdqhWY2gqXAkokz0iSTjQ=@protonmail.com
State New
Headers show
Series [bug#49619,1/2] Add pirate-get | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

phodina July 18, 2021, 11:37 a.m. UTC
And the pirate-get definition itself

---
index 40b93c4b30..eaf521090c 100644
--
2.31.1
diff mbox series

Patch

--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1778,6 +1778,33 @@  helpers.")
 appealing ASCII table format")
     (license license:bsd3)))

+(define-public python-pirate-get
+  (package
+    (name "python-pirate-get")
+    (version "0.4.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "pirate-get" version))
+        (sha256
+          (base32
+            "07s5ss9dxccx1mip7pyga1fagywkqchxmzz55ng47ac9053ffxkq"))))
+    (build-system python-build-system)
+    (propagated-inputs
+      `(("python-colorama" ,python-colorama)
+        ("python-pyperclip" ,python-pyperclip)
+        ("python-veryprettytable"
+         ,python-veryprettytable)))
+    (home-page
+      "https://github.com/vikstrous/pirate-get")
+    (synopsis
+      "A command line interface for The Pirate Bay")
+    (description
+      "pirate-get is a convenient command line tool (inspired by APT)
+to speed up your trip to the Pirate Bay and get your completely legal
+torrents more quickly.")
+    (license license:gpl3)))
+
 (define-public python2-humanfriendly
   (let ((base (package-with-python2
                 (strip-python2-variant python-humanfriendly))))