diff mbox series

[bug#49619,1/2] Add pirate-get

Message ID JuV3kXY4ae-0f4PzOqwU4h0_Vh24XCQbm0P3uWqIKZ_-_7hOqSjxqsSHPpVdGA1OPcVRuyq0GT5UNjV_a8ZrDHuaZmNbh81jQzI644BmQR8=@protonmail.com
State New
Headers show
Series [bug#49619,1/2] Add pirate-get | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

phodina July 18, 2021, 11:36 a.m. UTC
Add pkg veryprettytable as a dependency for pkg pirate-get

---
--
2.31.1

Comments

Sarah Morgensen July 21, 2021, 2:53 a.m. UTC | #1
merge 49619 49620
thanks

Hello,

Thanks for the patch. Please note that when submitting patchsets, only
the first patch should be sent to guix-patches@gnu.org; the rest should
be sent to the generated bug number, in this case 49619@debbugs.gnu.org,
in reply to the first email. You can find information about contributing
at:

  https://guix.gnu.org/manual/en/html_node/Submitting-Patches.html

I also have a few suggestions so your patch can be accepted.

phodina <phodina@protonmail.com> writes:

> Add pkg veryprettytable as a dependency for pkg pirate-get
>
> ---

Commit messages should follow the ChangeLog format; see the commit
history for examples. For example, this commit message would look like:

--8<---------------cut here---------------start------------->8---
gnu: Add python-veryprettytable.

* gnu/packages/python-xyz.scm (python-veryprettytable): New variable.
--8<---------------cut here---------------end--------------->8---

> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index d8c3fbec07..40b93c4b30 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -1754,6 +1754,30 @@ helpers.")
>      (properties `((python2-variant . ,(delay python2-humanfriendly))))
>      (license license:expat)))
>
> +(define-public python-veryprettytable
> +  (package
> +    (name "python-veryprettytable")
> +    (version "0.8.1")
> +    (source
> +      (origin
> +        (method url-fetch)
> +        (uri (pypi-uri "veryprettytable" version))
> +        (sha256
> +          (base32
> +            "1k1rifz8x6qcicmx2is9vgxcj0qb2f5pvzrp7zhmvbmci3yack3f"))))
> +    (build-system python-build-system)
> +    (propagated-inputs
> +      `(("python-colorama" ,python-colorama)
> +        ("python-termcolor" ,python-termcolor)))
> +    (home-page
> +      "https://github.com/smeggingsmegger/VeryPrettyTable")
> +    (synopsis
> +      "A visually appealing ASCII table output format")

Avoid starting synopses and descriptions with articles. "Visually
appealing..." would be fine.

> +    (description
> +      "A simple Python library for easily displaying tabular data in a visually
> +appealing ASCII table format")

Descriptions typically start: "VeryPrettyTable is a simple..."

The description for pirate-get should probably start "Pirate-get is
a..." or "@code{pirate-get} is a..."

> +    (license license:bsd3)))

This should be license:bsd-3.

> +
>  (define-public python2-humanfriendly
>    (let ((base (package-with-python2
>                  (strip-python2-variant python-humanfriendly))))
> --
> 2.31.1

You should also add your copyright at the top of the file, below all the
others.

Please use `--reroll-count=` when generating revised patchsets and
`--to=49169@debbugs.gnu.org --in-reply-to=<original patch's Message-ID>`
when sending.

--
Sarah
phodina Sept. 18, 2021, 8:07 a.m. UTC | #2
Hi Sarah!

Are these fixes now compliant to upstream the patch?
phodina Oct. 30, 2022, 8:22 p.m. UTC | #3
Hi,

this ticket has been dormant for some time.

Is it technically all right and can it be upstreamed or should it be closed due to being tied to "non-libre" service?

----
Petr
jgart Oct. 30, 2022, 10:23 p.m. UTC | #4
On Sun, 30 Oct 2022 20:22:35 +0000 phodina <phodina@protonmail.com> wrote:
> Is it technically all right and can it be upstreamed or should it be closed due to being tied to "non-libre" service?
> 

The fact that this software interacts with a "non-libre" service/backend should not be a blocker for Guix.

all best,

jgart
phodina Dec. 25, 2022, 6:01 p.m. UTC | #5
Hi Ludo’,

another ancient package that fell through :-)


----
Petr
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d8c3fbec07..40b93c4b30 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1754,6 +1754,30 @@  helpers.")
     (properties `((python2-variant . ,(delay python2-humanfriendly))))
     (license license:expat)))

+(define-public python-veryprettytable
+  (package
+    (name "python-veryprettytable")
+    (version "0.8.1")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "veryprettytable" version))
+        (sha256
+          (base32
+            "1k1rifz8x6qcicmx2is9vgxcj0qb2f5pvzrp7zhmvbmci3yack3f"))))
+    (build-system python-build-system)
+    (propagated-inputs
+      `(("python-colorama" ,python-colorama)
+        ("python-termcolor" ,python-termcolor)))
+    (home-page
+      "https://github.com/smeggingsmegger/VeryPrettyTable")
+    (synopsis
+      "A visually appealing ASCII table output format")
+    (description
+      "A simple Python library for easily displaying tabular data in a visually
+appealing ASCII table format")
+    (license license:bsd3)))
+
 (define-public python2-humanfriendly
   (let ((base (package-with-python2
                 (strip-python2-variant python-humanfriendly))))