diff mbox series

[bug#57944,1/2] gnu: Add gnome-text-editor

Message ID J4Pv76Szb_-uwrWO7DS4Lp5z55Xwk0iMQylkckmfSLDBOFJm5G4MMEqqfpLdSNa277GUMjnx6HZoweN1kWvwH2Z3avczDFsH8auPji8yabM=@proton.me
State Accepted
Headers show
Series [bug#57944,1/2] gnu: Add gnome-text-editor | expand

Commit Message

Sughosha Sept. 20, 2022, 9:12 a.m. UTC
Thanks for reviewing. I made the changes with the corrections. Here are new patches with the fixes. But one thing I am not sure why gpl3+ was suggested, while in the GitLab repository it is mentioned as GNU GPLv3.

------- Original Message -------
Liliana Marie Prikler <liliana.prikler@gmail.com> schrieb am Dienstag, 20. September 2022 um 07:14:


> Hi,
> 
> Am Dienstag, dem 20.09.2022 um 04:13 +0000 schrieb Sughosha:
> 
> > + (uri (string-append "mirror://gnome/sources/gnome-
> > text-editor/"
> > + (version-major version)
> > + "/"
> > + "gnome-text-editor-"
> > + version
> > + ".tar.xz"))
> 
> The format provided by the pretty-printer is, like, a suggestion.
> 
> > + (build-system meson-build-system)
> > + (native-inputs (list pkg-config
> 
> You're missing arguments here. At the very least #:glib-or-gtk? #t
> 
> > + "Text Editor is a simple text editor that focuses on session
> > management.
> > +It works hard to keep track of changes and state even if you quit
> > the
> > +application. You can come back to your work even if you've never
> > saved it to a
> > +file."
> 
> You should probably call it GNOME Text Editor. The description is
> fairly light on advertisments as far as copypasta descriptions go, so I
> won't fault you for that here.
> 
> > + (license license:gpl3)))
> 
> Should probably be gpl3+.
> 
> > + (synopsis "Simple user-friendly terminal emulator for the GNOME
> > desktop")
> > + (description
> > + "Console is supposed to be a simple terminal emulator for the
> > average user
> > +to carry out simple cli tasks and aims to be a ‘core’ app for
> > GNOME/Phosh")
> 
> Ehhhhhh... I do want you to cut down on the ads here.
> 
> > + (build-system meson-build-system)
> > + (native-inputs (list desktop-file-utils
> 
> Missing arguments.
> 
> > + (home-page "https://gitlab.gnome.org/GNOME/gnome-console")
> 
> Dead link is dead.
> 
> > + (license license:gpl3)))
> 
> Also probably gpl3+.
> 
> Cheers
diff mbox series

Patch

From 8142d2bc994e1b7cc61ad379f9ce13ee7e274ec0 Mon Sep 17 00:00:00 2001
From: Sughosha <sughosha@proton.me>
Date: Tue, 20 Sep 2022 06:08:05 +0200
Subject: [PATCH 2/2] gnu: Add gnome-console

* gnu/packages/gnome.scm (gnome-console): New variable.
---
 gnu/packages/gnome.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index c76b25d968..14e9c36fc6 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5411,6 +5411,38 @@  (define-public gnome-sudoku
 more fun.")
     (license license:gpl2+)))
 
+(define-public gnome-console
+  (package
+    (name "gnome-console")
+    (version "42.2")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://gnome/sources/gnome-console/"
+                                  (version-major version) "/"
+                                  "gnome-console-" version ".tar.xz"))
+              (sha256
+               (base32
+                "0jbh8g3hmc35fy5fbscqf0831xpg1kv66ci9hykpbia4hz0yc9kx"))))
+    (build-system meson-build-system)
+    (arguments
+     `(#:glib-or-gtk? #t
+       #:configure-flags
+       `("-Dtests=true")))
+    (native-inputs (list `(,glib "bin")
+                         gettext-minimal
+                         sassc
+                         pkg-config
+                         `(,gtk+ "bin")
+                         desktop-file-utils))
+    (inputs (list gtk+
+                  libhandy
+                  vte
+                  libgtop
+                  gsettings-desktop-schemas))
+    (home-page "https://gitlab.gnome.org/GNOME/console")
+    (synopsis "GNOME terminal emulator")
+    (description
+     "Console is a simple terminal emulator for GNOME desktop")
+    (license license:gpl3+)))
+
 (define-public gnome-terminal
   (package
     (name "gnome-terminal")
-- 
2.37.3