diff mbox series

[bug#48899,v2,2/2] gnu: Update license.

Message ID Fmd2Z4bFyhyHonsNdgyJZJftF4nimGVgRKxJLm7DQ-Hd4wfif9pv-yS8Cf5qWzrMLSCPyRhyFdoHkKJ0Ix20JarqeesVMr7tLygQYdml6VU=@protonmail.com
State Accepted
Headers show
Series [bug#48899] : gnu: Add lowdown. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

phodina Nov. 5, 2021, 5:49 a.m. UTC
* gnu/packages/markup.scm (hoedown, markdown, discount,
perl-text-markdown-discount, cmark, smu, md4c, python-mistletoe)
[license]: Add prefix license:.

--
2.33.1

Comments

Liliana Marie Prikler Nov. 5, 2021, 8:42 p.m. UTC | #1
Hi Petr,

Am Freitag, den 05.11.2021, 05:49 +0000 schrieb phodina:
> * gnu/packages/markup.scm (hoedown, markdown, discount,
> perl-text-markdown-discount, cmark, smu, md4c, python-mistletoe)
> [license]: Add prefix license:.
Pushed with slight changes to commit message and ChangeLog, as well as

> @@ -115,7 +115,7 @@ (define-public markdown
>       "Markdown is a text-to-HTML conversion tool for web
> writers.  It allows
>  you to write using an easy-to-read, easy-to-write plain text format,
> then
>  convert it to structurally valid XHTML (or HTML).")
> -    (license (non-copyleft "file://License.text"
> +    (license (license:non-copyleft "file://License.text"
>                             "See License.text in the
> distribution."))))
indented this hunk.

Also added the license use statement where the previous one was and
deleted the previous to enforce use of license:

Thanks
diff mbox series

Patch

diff --git a/gnu/packages/markup.scm b/gnu/packages/markup.scm
index 720bdb178b..91aa7b8fa0 100644
--- a/gnu/packages/markup.scm
+++ b/gnu/packages/markup.scm
@@ -71,7 +71,7 @@  (define-public hoedown
     (description "Hoedown is a standards compliant, fast, secure markdown
 processing library written in C.")
     (home-page "https://github.com/hoedown/hoedown")
-    (license expat)))
+    (license license:expat)))

 (define-public markdown
   (package
@@ -115,7 +115,7 @@  (define-public markdown
      "Markdown is a text-to-HTML conversion tool for web writers.  It allows
 you to write using an easy-to-read, easy-to-write plain text format, then
 convert it to structurally valid XHTML (or HTML).")
-    (license (non-copyleft "file://License.text"
+    (license (license:non-copyleft "file://License.text"
                            "See License.text in the distribution."))))

 (define-public lowdown
@@ -192,7 +192,7 @@  (define-public discount
      "Discount is a markdown implementation, written in C.  It provides a
 @command{markdown} command, and a library.")
     (home-page "https://www.pell.portland.or.us/~orc/Code/discount/")
-    (license bsd-3)))
+    (license license:bsd-3)))

 (define-public perl-text-markdown-discount
   (package
@@ -237,7 +237,7 @@  (define-public perl-text-markdown-discount
   use Text::Markdown::Discount;
   my $html = markdown($text)
 @end example")
-    (license perl-license)))
+    (license license:perl-license)))

 (define-public cmark
   (package
@@ -277,7 +277,7 @@  (define-public cmark
     ;; cmark is distributed with a BSD-2 license, but some components are Expat
     ;; licensed. The CommonMark specification is Creative Commons CC-BY-SA 4.0
     ;; licensed. See 'COPYING' in the source distribution for more information.
-    (license (list bsd-2 expat cc-by-sa4.0))))
+    (license (list license:bsd-2 license:expat license:cc-by-sa4.0))))

 (define-public smu
   (package
@@ -313,7 +313,7 @@  (define-public smu
 Smu was started as a rewrite of Markdown but became something more
 lightweight and consistent.  The biggest difference between Markdown
 and smu is that smu doesn't support reference style links.")
-    (license x11)))
+    (license license:x11)))

 (define-public md4c
   (package
@@ -335,7 +335,7 @@  (define-public md4c
     (description "MD4C is a C Markdown parser with a
 SAX-like interface.  It is compliant to the CommonMark specification,
 with a few extensions.")
-    (license expat)))
+    (license license:expat)))

 (define-public python-mistletoe
   (package
@@ -357,4 +357,4 @@  (define-public python-mistletoe
 Parsing Markdown into an abstract syntax tree also allows @code{mistletoe} to
 swap out renderers for different output formats, without touching any of the
 core components.")
-    (license expat)))
+    (license license:expat)))