diff mbox series

[bug#48899] : gnu: Add lowdown.

Message ID 86czsxamoz.fsf@163.com
State Accepted
Headers show
Series [bug#48899] : gnu: Add lowdown. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Zhu Zihao June 7, 2021, 12:22 p.m. UTC

Comments

Zhu Zihao July 6, 2021, 3:05 a.m. UTC | #1
ping.
diff mbox series

Patch

From 15feae91f6192f22d519968c9849de512eaaf525 Mon Sep 17 00:00:00 2001
From: Zhu Zihao <all_but_last@163.com>
Date: Mon, 7 Jun 2021 20:17:22 +0800
Subject: [PATCH] gnu: Add lowdown.

* gnu/packages/markup.scm(lowdown): New variable.
---
 gnu/packages/markup.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)

diff --git a/gnu/packages/markup.scm b/gnu/packages/markup.scm
index 368976bfde..0a643809aa 100644
--- a/gnu/packages/markup.scm
+++ b/gnu/packages/markup.scm
@@ -114,6 +114,36 @@  convert it to structurally valid XHTML (or HTML).")
     (license (non-copyleft "file://License.text"
                            "See License.text in the distribution."))))
 
+(define-public lowdown
+  (package
+    (name "lowdown")
+    (version "0.8.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://kristaps.bsd.lv/lowdown/snapshots/lowdown-"
+                           version ".tar.gz"))
+       (sha256
+        (base32 "1f6lpyz5bbvwqadal8xcfjcm46zcycrgk5079isjyipg85zdyvb2"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f                      ;No test
+       #:phases
+       (modify-phases %standard-phases
+         (replace 'configure
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let ((out (assoc-ref outputs "out")))
+               (invoke "./configure"
+                       (string-append "PREFIX=" out)
+                       (string-append "MANDIR=" out "/share/man"))))))))
+    (native-inputs
+     `(("which" ,which)))
+    (home-page "https://kristaps.bsd.lv/lowdown")
+    (synopsis "Simple Markdown translator")
+    (description "Lowdown is a Markdown translator producing HTML5,
+roff documents in the ms and man formats, LaTeX, gemini, and terminal output.")
+    (license license:isc)))
+
 (define-public discount
   (package
     (name "discount")
-- 
2.31.1