diff mbox series

[bug#67515,01/91] gnu: Add blueprint-compiler-next.

Message ID DU2P193MB21327F5E8657DB360816CECAF3BCA@DU2P193MB2132.EURP193.PROD.OUTLOOK.COM
State New
Headers show
Series [bug#67515,01/91] gnu: Add blueprint-compiler-next. | expand

Commit Message

Sergio Pastor PĂ©rez Nov. 28, 2023, 9:11 p.m. UTC
* gnu/packages/gnome.scm (blueprint-compiler-next): New variable.

Change-Id: I6f2e69c33ac99b0bab4e38b6f4d1a9c068127d2e
---
 gnu/packages/gnome.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index d354327497..bbae946ec6 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3282,6 +3282,25 @@  (define-public blueprint-compiler
     (home-page "https://gitlab.gnome.org/jwestman/blueprint-compiler")
     (license license:lgpl3+)))
 
+(define-public blueprint-compiler-next
+  (package
+    (inherit blueprint-compiler)
+    (name "blueprint-compiler")
+    (version "0.10.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url
+                     "https://gitlab.gnome.org/jwestman/blueprint-compiler")
+                    (commit (string-append "v" version))))
+              (file-name (string-append name "-" version "-checkout"))
+              (sha256
+               (base32
+                "0g3rk9rkl92phhjam3b17pw8l0r482jh7zs8wxz87wq3c9rx1ym4"))))
+    (arguments (cons*
+                #:tests? #f
+                (package-arguments blueprint-compiler)))))
+
 (define-public cambalache
   (package
     (name "cambalache")