diff mbox series

[bug#67515,33/91] gnu: Add rust-coverage-helper-0.1.

Message ID DU2P193MB213202368A0E2F37B87D34C0F3BCA@DU2P193MB2132.EURP193.PROD.OUTLOOK.COM
State New
Headers show
Series [bug#67515,01/91] gnu: Add blueprint-compiler-next. | expand

Commit Message

Sergio Pastor PĂ©rez Nov. 28, 2023, 9:12 p.m. UTC
* gnu/packages/crates-io.scm (rust-coverage-helper-0.1): New variable.

Change-Id: Iee9040b7cb16859880ed37f72ea91b0f85877538
---
 gnu/packages/crates-io.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 197d9e3e33..cf5a2533ad 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -16236,6 +16236,25 @@  (define-public rust-cov-mark-2
     (description "This package provides a Manual coverage marks.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-coverage-helper-0.1
+  (package
+    (name "rust-coverage-helper")
+    (version "0.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "coverage_helper" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1zpk3k8r7rzc84xp45qww0kix7s9iv92xajndi5c3wvw8w753nx9"))))
+    (build-system cargo-build-system)
+    (home-page "https://github.com/taiki-e/coverage-helper")
+    (synopsis
+     "Helper for <https://github.com/taiki-e/cargo-llvm-cov/issues/123>.")
+    (description
+     "Helper for <https://github.com/taiki-e/cargo-llvm-cov/issues/123>.")
+    (license (list license:asl2.0 license:expat))))
+
 (define-public rust-count-instructions-0.1
   (package
     (name "rust-count-instructions")