diff mbox series

[bug#66547,1/2] gnu: Add sfsexp.

Message ID DU2P193MB2132717D8F22956768A4A155F3D1A@DU2P193MB2132.EURP193.PROD.OUTLOOK.COM
State New
Headers show
Series Update `notmuch' package to support sexp queries | expand

Commit Message

Sergio Pastor PĂ©rez Oct. 14, 2023, 7:28 p.m. UTC
* gnu/packages/c.scm (sfsexp): New variable.
---
 gnu/packages/c.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index ea58c68262..0a63b81188 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -571,6 +571,29 @@  (define-public libwuya
       ;; clarified (see: https://github.com/WuBingzheng/libwuya/issues/2).
       (license license:gpl2+))))
 
+(define-public sfsexp
+  (package
+    (name "sfsexp")
+    (version "1.4.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/mjsottile/sfsexp")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "03srnpc7p1j7ygd0wx9gybcxhqm50kjzkybh1xs75nwz97q3y2dq"))))
+    (build-system gnu-build-system)
+    (native-inputs (list autoconf automake libtool))
+    (home-page "https://github.com/mjsottile/sfsexp")
+    (synopsis "Small Fast S-Expression Library")
+    (description
+     "Sfsexp provides an interface to manipulate (read, parse, modify, and
+create) symbolic expressions from C or C++ programs.  A symbolic expression,
+or s-expression, is essentially a LISP-like expression such as (a (b c)).")
+    (license license:gpl2)))
+
 (define-public packcc
   (package
     (name "packcc")