diff mbox series

[bug#66547,2/2] gnu: notmuch: Update to support sexp queries.

Message ID DU2P193MB2132471F4137BA1813230727F3D1A@DU2P193MB2132.EURP193.PROD.OUTLOOK.COM
State New
Headers show
Series Update `notmuch' package to support sexp queries | expand

Commit Message

Sergio Pastor PĂ©rez Oct. 14, 2023, 7:28 p.m. UTC
* gnu/packages/mail.scm (notmuch): Update to support sexp queries.
---
 gnu/packages/mail.scm | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index be458a2d92..f330b1d8a2 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -80,6 +80,7 @@  (define-module (gnu packages mail)
   #:use-module (gnu packages bash)
   #:use-module (gnu packages bison)
   #:use-module (gnu packages boost)
+  #:use-module (gnu packages c)
   #:use-module (gnu packages calendar)
   #:use-module (gnu packages check)
   #:use-module (gnu packages compression)
@@ -1403,13 +1404,15 @@  (define-public notmuch
            python-docutils
            python-sphinx
            texinfo
+           sfsexp               ; required to support sexp queries
            ;; The following are required for tests only.
            emacs-no-x           ; -minimal lacks libxml, needed for some tests
            which
            dtach
            gnupg
            man-db
-           perl))
+           perl
+           git))                ; required by the sexp query tests
     (inputs
      (list glib gmime talloc xapian zlib))
     (home-page "https://notmuchmail.org/")