diff mbox series

[bug#54311] gnu: tint2: Update to 17.0.2.

Message ID DM5PR04MB377206E5B815F5882E53C0E9990A9@DM5PR04MB3772.namprd04.prod.outlook.com
State Accepted
Headers show
Series [bug#54311] gnu: tint2: Update to 17.0.2. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Wamm K. D March 9, 2022, 7:34 p.m. UTC
---
Noticed that the version currently is ~4 years old from the latest…
 gnu/packages/xdisorg.scm | 11 ++++++-----
 1 file changed, 6 insertions(+), 5 deletions(-)

Comments

M March 9, 2022, 8:28 p.m. UTC | #1
Wamm K. D schreef op wo 09-03-2022 om 13:34 [-0600]:
>       '(#:tests? #f                      ;no test target


There seem to be some tests in the 'test' directory.

>              #t)))))

Trailing #t aren't necessary anymore.

Greetings,
M March 9, 2022, 8:30 p.m. UTC | #2
Wamm K. D schreef op wo 09-03-2022 om 13:34 [-0600]:
> +              (uri (string-append "https://gitlab.com/o9000/" name "/-/archive/"
> +                                  version "/" name "-" version ".tar.gz"))

Is this uri stable?

Also, there seems to be a 'v' missing before version.  Does
"guix download
https://gitlab.com/o9000/tint2/-/archive/17.0.2/tint2-17.0.2.tar.gz"
succeed?

Greetings,
Maxime.
M March 9, 2022, 8:31 p.m. UTC | #3
Wamm K. D schreef op wo 09-03-2022 om 13:34 [-0600]:
> @@ -1811,7 +1812,7 @@ (define-public tint2
>                 (("/etc") "${CMAKE_INSTALL_PREFIX}/etc"))

Is this still necessary?

Greetings,
Maxime.
Wamm K. D March 9, 2022, 9:46 p.m. UTC | #4
> On Wednesday, March 9, 2022, 02:30:14 PM CST, Maxime Devos <maximedevos@telenet.be> wrote: 
>
>
>
>
>
> Wamm K. D schreef op wo 09-03-2022 om 13:34 [-0600]:
>
> > +              (uri (string-append "https://gitlab.com/o9000/" name "/-/archive/"
> > +                                  version "/" name "-" version ".tar.gz"))
>
>
> Is this uri stable?

I think it's a standard GitLab URL? It's what was given when choosing to download the .tar.gz file from GitLab; I went with it to avoid a lot of changes to the original package definition but, given it's just Git, we could just use a git-download instead. Let me know if that's preferred.

> Also, there seems to be a 'v' missing before version.  Does
> "guix download
> https://gitlab.com/o9000/tint2/-/archive/17.0.2/tint2-17.0.2.tar.gz"
> succeed?

It does (I'm running version 17.0.2 on my machine, right now); the tint2 project tags versions with both no "v" and with a "v" so either would work. Both "https://gitlab.com/o9000/tint2/-/archive/17.0.2/tint2-17.0.2.tar.gz" and "https://gitlab.com/o9000/tint2/-/archive/v17.0.2/tint2-v17.0.2.tar.gz" should be valid (https://gitlab.com/o9000/tint2/-/tags).
Tobias Geerinckx-Rice March 9, 2022, 9:57 p.m. UTC | #5
What Maxime means is that some forges (like GitHub) generate these archives on the fly, instead of the author uploading a 'stable' file.  You can usually tell them apart by the URL, but I forget GitLab's conventions.

These archives might be cached for a while but if they are regenerated the hash could change even if the unpacked data didn't.  This has happened in the past and breaks e.g. guix time-machine even if 'fixed' on master.

Hence we prefer git-fetch when available, or tarballs that look human-generated.

Kind regards,

T G-R

Sent on the go.  Excuse or enjoy my brevity.
Wamm K. D March 9, 2022, 10:16 p.m. UTC | #6
> On Wednesday, March 9, 2022, 03:57:51 PM CST, Tobias Geerinckx-Rice <me@tobias.gr> wrote: 
>
>
>
>
>
> What Maxime means is that some forges (like GitHub) generate these archives on the fly, instead of the author uploading a 'stable' file.  You can usually tell them apart by the URL, but I forget GitLab's conventions.
>
> These archives might be cached for a while but if they are regenerated the hash could change even if the unpacked data didn't.  This has happened in the past and breaks e.g. guix time-machine even if 'fixed' on master.
>
> Hence we prefer git-fetch when available, or tarballs that look human-generated.
>
> Kind regards,
>
> T G-R

Ahhh; I see. Thanks a ton for the explanation, Tobias. I'll get this switched over to git-fetch, Maxime, while I look over your other feedback.
diff mbox series

Patch

diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 6dc40f0910..f5d981413c 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -54,6 +54,7 @@ 
 ;;; Copyright © 2021 jgart <jgart@dismail.de>
 ;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
 ;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
+;;; Copyright © 2022 Wamm K. D. <jaft.r@outlook.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1791,15 +1792,15 @@  (define-public rofi-calc
 (define-public tint2
   (package
     (name "tint2")
-    (version "0.14.6")
+    (version "17.0.2")
     (source (origin
               (method url-fetch)
-              (uri (string-append "https://gitlab.com/o9000/" name
-                                  "/repository/archive.tar.gz?ref=" version))
+              (uri (string-append "https://gitlab.com/o9000/" name "/-/archive/"
+                                  version "/" name "-" version ".tar.gz"))
               (file-name (string-append name "-" version ".tar.gz"))
               (sha256
                (base32
-                "1kwzwxy4myagybm3rc7dgynfgp75742n348qibn1p2an9ggyivda"))))
+                "0k72kjr4rmprbrhs5ik1g7vwdi2lbzvkf5zw28gz6ckd2xz18zzq"))))
     (build-system cmake-build-system)
     (arguments
      '(#:tests? #f                      ;no test target
@@ -1811,7 +1812,7 @@  (define-public tint2
                (("/etc") "${CMAKE_INSTALL_PREFIX}/etc"))
              #t)))))
     (inputs
-     (list gtk+-2
+     (list gtk+
            imlib2
            librsvg
            libxcomposite